Medium
vips — security advisory
libvips is a fast image processing library with low memory needs. On 32-bit systems in versions before and including 8.18.0, the `gifload` operation could incorrectly determine dimensions leading to an integer overflow. This has been patched in version 8.18.1.
- Products
- vips
- Affected versions
- 8.14.3-1, 8.14.5-1, 8.15.0-1, 8.15.0-2, 8.15.1-1, 8.15.1-1.1build3, 8.15.1-1.1build4, 8.15.1-1.1ubuntu0.1~esm1, 8.15.1-1build1, 8.16.1-1, 8.16.1-2, 8.17.3-2, 8.18.0-1, 8.18.0-1build1, 8.18.0-1ubuntu0.1~esm1
- Fixed versions
- Not specified
- CVEs
- CVE-2026-33328
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 10:27 UTC · Revision 1
Source evidence
libvips is a fast image processing library with low memory needs. On 32-bit systems in versions before and including 8.18.0, the `gifload` operation could incorrectly determine dimensions leading to an integer overflow. This has been patched in version 8.18.1.
osv:UBUNTU-CVE-2026-33328
vips
Fixed versions: Not specified
vips
Fixed versions: Not specified
Complete source record
{
"id": "3228e1d26f06dc189d37407e1e77816c4d576f353346dea2431b4264d2ede7d1",
"url": "https://osv.dev/vulnerability/UBUNTU-CVE-2026-33328",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "UBUNTU-CVE-2026-33328",
"summary": "libvips is a fast image processing library with low memory needs. On 32-bit systems in versions before and including 8.18.0, the `gifload` operation could incorrectly determine dimensions leading to an integer overflow. This has been patched in version 8.18.1.",
"evidence": "osv:UBUNTU-CVE-2026-33328",
"products": [
{
"name": {
"value": "vips",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "8.14.3-1",
"evidence": "/affected/0/versions"
},
{
"value": "8.14.5-1",
"evidence": "/affected/0/versions"
},
{
"value": "8.15.0-1",
"evidence": "/affected/0/versions"
},
{
"value": "8.15.0-2",
"evidence": "/affected/0/versions"
},
{
"value": "8.15.1-1",
"evidence": "/affected/0/versions"
},
{
"value": "8.15.1-1build1",
"evidence": "/affected/0/versions"
},
{
"value": "8.15.1-1.1build3",
"evidence": "/affected/0/versions"
},
{
"value": "8.15.1-1.1build4",
"evidence": "/affected/0/versions"
},
{
"value": "8.15.1-1.1ubuntu0.1~esm1",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "vips",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "8.16.1-1",
"evidence": "/affected/1/versions"
},
{
"value": "8.16.1-2",
"evidence": "/affected/1/versions"
},
{
"value": "8.17.3-2",
"evidence": "/affected/1/versions"
},
{
"value": "8.18.0-1",
"evidence": "/affected/1/versions"
},
{
"value": "8.18.0-1build1",
"evidence": "/affected/1/versions"
},
{
"value": "8.18.0-1ubuntu0.1~esm1",
"evidence": "/affected/1/versions"
}
]
}
],
"severity": "medium",
"structured": {
"id": "UBUNTU-CVE-2026-33328",
"aliases": [
"UBUNTU-CVE-2026-33328"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N"
},
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H"
},
{
"type": "Ubuntu",
"score": "medium"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "vips",
"purl": "pkg:deb/ubuntu/vips?arch=source&distro=esm-apps%2Fnoble",
"ecosystem": "Ubuntu:Pro:24.04:LTS"
},
"versions": [
"8.14.3-1",
"8.14.5-1",
"8.15.0-1",
"8.15.0-2",
"8.15.1-1",
"8.15.1-1build1",
"8.15.1-1.1build3",
"8.15.1-1.1build4",
"8.15.1-1.1ubuntu0.1~esm1"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2026/UBUNTU-CVE-2026-33328.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "gir1.2-vips-8.0",
"binary_version": "8.15.1-1.1ubuntu0.1~esm1"
},
{
"binary_name": "libvips-tools",
"binary_version": "8.15.1-1.1ubuntu0.1~esm1"
},
{
"binary_name": "libvips42t64",
"binary_version": "8.15.1-1.1ubuntu0.1~esm1"
}
]
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "vips",
"purl": "pkg:deb/ubuntu/vips?arch=source&distro=esm-apps%2Fresolute",
"ecosystem": "Ubuntu:Pro:26.04:LTS"
},
"versions": [
"8.16.1-1",
"8.16.1-2",
"8.17.3-2",
"8.18.0-1",
"8.18.0-1build1",
"8.18.0-1ubuntu0.1~esm1"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2026/UBUNTU-CVE-2026-33328.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "gir1.2-vips-8.0",
"binary_version": "8.18.0-1ubuntu0.1~esm1"
},
{
"binary_name": "libvips-tools",
"binary_version": "8.18.0-1ubuntu0.1~esm1"
},
{
"binary_name": "libvips42t64",
"binary_version": "8.18.0-1ubuntu0.1~esm1"
}
]
}
}
],
"modified": "2026-10-25T23:30:05.197381111Z",
"provider": "osv",
"upstream": [
"CVE-2026-33328"
],
"references": [
"https://ubuntu.com/security/CVE-2026-33328",
"https://www.cve.org/CVERecord?id=CVE-2026-33328",
"https://github.com/libvips/libvips/security/advisories/GHSA-r98w-4fp7-m9c7",
"https://github.com/libvips/libvips/pull/4935"
]
},
"related_cves": [
{
"value": "CVE-2026-33328",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 446249,
"published_at": "2026-07-20T17:17:00+00:00"
}