High
Post SMTP < 2.8.7 - Admin+ SQL Injection
Type: advisorySources: OSV
The POST SMTP Mailer WordPress plugin before 2.8.7 does not properly sanitise and escape several parameters before using them in SQL statements, leading to a SQL injection exploitable by high privilege users such as admin.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2023-6620
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 7 Nov 2026, 10:22 UTC · Revision 1
Source evidence
The POST SMTP Mailer WordPress plugin before 2.8.7 does not properly sanitise and escape several parameters before using them in SQL statements, leading to a SQL injection exploitable by high privilege users such as admin.
osv:CVE-2023-6620
Complete source record
{
"id": "055646826b8fc0bc3514f5e6f6b7ab8b3753d70fd07952011bc3134f390a3d24",
"url": "https://osv.dev/vulnerability/CVE-2023-6620",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Post SMTP < 2.8.7 - Admin+ SQL Injection",
"summary": "The POST SMTP Mailer WordPress plugin before 2.8.7 does not properly sanitise and escape several parameters before using them in SQL statements, leading to a SQL injection exploitable by high privilege users such as admin.",
"evidence": "osv:CVE-2023-6620",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2023-6620",
"aliases": [
"CVE-2023-6620"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/wpexpertsio/post-smtp",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "437956ad80f774c66350ad620f75262cd50ebc34"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:wpexperts:post_smtp:*:*:*:*:*:wordpress:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "2.8.7"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"2.5.9-beta.1",
"2.8.5",
"2.8.4",
"2.7.0",
"2.8.3",
"2.7.2",
"2.6.0",
"2.5.9.4",
"2.5.9.3",
"2.5.8",
"2.5.7",
"2.5.6",
"2.5.5",
"2.5.4",
"2.5.3",
"2.5.2",
"2.5.1",
"2.5.0",
"2.5-rc.3",
"2.5-rc.2",
"2.5-rc.1",
"2.5-beta.1",
"2.4.3",
"2.4.2-beta.2",
"2.4.2",
"2.4.1",
"2.4",
"2.4-beta.1",
"2.3.1",
"2.3",
"2.2.1",
"2.2",
"2.2-beta.2",
"2.1.8",
"2.1.7",
"2.1.6",
"2.1.4",
"2.1.4-rc.2",
"2.1.4-rc.1",
"2.1.4-beta.1",
"2.1.2",
"2.1.2-rc.2",
"2.1.2-rc.1",
"2.1.2-beta-1",
"2.1.1.1",
"2.1.1",
"2.1",
"2.1-beta.1",
"2.0.27",
"2.0.26",
"2.0.25-beta.1",
"2.0.25",
"2.0.24",
"2.0.23",
"2.0.22",
"2.0.21",
"2.0.20",
"2.0.19",
"2.0.18",
"2.0.17",
"2.0.16",
"2.0.15",
"2.0.14",
"2.0.13",
"2.0.12",
"2.0.11",
"2.0.10",
"2.0.9",
"2.0.8",
"2.0.7",
"2.0.6",
"2.0.5",
"2.0.4",
"2.0.3",
"2.0.2",
"2.0.1",
"v1.9.8",
"v1.9.7",
"v1.9.6",
"v1.9.5",
"v1.9.4",
"v1.9.3",
"v.1.9.2",
"v.1.9.1",
"v.1.9.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-6620.json"
}
}
],
"modified": "2026-10-28T02:30:50.341166703Z",
"provider": "osv",
"references": [
"https://wordpress.org/plugins",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/6xxx/CVE-2023-6620.json",
"https://nvd.nist.gov/vuln/detail/CVE-2023-6620",
"https://wpscan.com/vulnerability/ab5c42ca-ee7d-4344-bd88-0d727ed3d9c4"
],
"provider_metadata": {
"cna_assigner": "WPScan",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"fixed": "2.8.7"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/6xxx/CVE-2023-6620.json"
}
},
"related_cves": [
{
"value": "CVE-2023-6620",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 518992,
"published_at": "2024-01-15T15:10:41.386+00:00"
}