Skip to content
Heist/ feed
Back to feed
Critical

Auth0-PHP SDK Deserialization of Untrusted Data vulnerability

Type: advisorySources: OSV

Auth0-PHP is a PHP SDK for Auth0 Authentication and Management APIs. Versions 8.0.0-BETA3 prior to 8.3.1 contain a vulnerability due to insecure deserialization of cookie data. If exploited, since SDKs process cookie content without prior authentication, a threat actor could send a specially crafted cookie containing malicious serialized data. Applications using the Auth0-PHP SDK are affected, as are applications using the Auth0/symfony, Auth0/laravel-auth0, or Auth0/wordpress SDKs, because those SDKsrely on the Auth0-PHP SDK versions from 8.0.0-BETA3 until 8.14.0. Version 8.3.1 contains a patch for the issue.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2025-48951
Confirmed fixed CVEs
Not specified
Updated in this feed
7 Nov 2026, 05:32 UTC · Revision 1

Source evidence

Auth0-PHP SDK Deserialization of Untrusted Data vulnerability

core-osv · Original source

Published 3 Jun 2025, 20:52 UTC

Auth0-PHP is a PHP SDK for Auth0 Authentication and Management APIs. Versions 8.0.0-BETA3 prior to 8.3.1 contain a vulnerability due to insecure deserialization of cookie data. If exploited, since SDKs process cookie content without prior authentication, a threat actor could send a specially crafted cookie containing malicious serialized data. Applications using the Auth0-PHP SDK are affected, as are applications using the Auth0/symfony, Auth0/laravel-auth0, or Auth0/wordpress SDKs, because those SDKsrely on the Auth0-PHP SDK versions from 8.0.0-BETA3 until 8.14.0. Version 8.3.1 contains a patch for the issue.

osv:CVE-2025-48951
Complete source record
{
  "id": "047e13a528813adaed52a975eb105cc26f82cee6eab42e8499fa1e8b9116acea",
  "url": "https://osv.dev/vulnerability/CVE-2025-48951",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "Auth0-PHP SDK Deserialization of Untrusted Data vulnerability",
    "summary": "Auth0-PHP is a PHP SDK for Auth0 Authentication and Management APIs. Versions 8.0.0-BETA3 prior to 8.3.1 contain a vulnerability due to insecure deserialization of cookie data. If exploited, since SDKs process cookie content without prior authentication, a threat actor could send a specially crafted cookie containing malicious serialized data. Applications using the Auth0-PHP SDK are affected, as are applications using the Auth0/symfony, Auth0/laravel-auth0, or Auth0/wordpress SDKs, because those SDKsrely on the Auth0-PHP SDK versions from 8.0.0-BETA3 until 8.14.0. Version 8.3.1 contains a patch for the issue.",
    "evidence": "osv:CVE-2025-48951",
    "products": [],
    "severity": "critical",
    "structured": {
      "id": "CVE-2025-48951",
      "aliases": [
        "CVE-2025-48951",
        "GHSA-v9m8-9xxp-q492"
      ],
      "metrics": [
        {
          "type": "CVSS_V4",
          "score": "CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:H/SI:H/SA:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/auth0/auth0-php",
              "type": "GIT",
              "events": [
                {
                  "introduced": "c0168fe385e18d8a2cd3980512142cc2449bea0b"
                },
                {
                  "fixed": "848c702e2ea58c8dba0cae30976953b5772f8bf0"
                },
                {
                  "fixed": "04b1f5daa8bdfebc5e740ec5ca0fb2df1648a715"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "range": [
                      {
                        "introduced": "8.0.0-BETA3"
                      },
                      {
                        "fixed": "8.3.1"
                      }
                    ],
                    "source": "AFFECTED_FIELD",
                    "strategy": "StringRangeExpression"
                  },
                  {
                    "range": [
                      {
                        "fixed": "04b1f5daa8bdfebc5e740ec5ca0fb2df1648a715"
                      }
                    ],
                    "source": "REFERENCES_COMMIT"
                  }
                ]
              }
            }
          ],
          "versions": [
            "8.3.0",
            "8.2.1",
            "8.2.0",
            "8.1.0",
            "8.0.6",
            "8.0.5",
            "8.0.4",
            "8.0.3",
            "8.0.2",
            "8.0.1",
            "8.0.0",
            "8.0.0-BETA3"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-48951.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:50.173177486Z",
      "provider": "osv",
      "references": [
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/48xxx/CVE-2025-48951.json",
        "https://github.com/auth0/auth0-PHP/security/advisories/GHSA-v9m8-9xxp-q492",
        "https://github.com/auth0/laravel-auth0/security/advisories/GHSA-c42h-56wx-h85q",
        "https://github.com/auth0/symfony/security/advisories/GHSA-98j6-67v3-mw34",
        "https://github.com/auth0/wordpress/security/advisories/GHSA-862m-5253-832r",
        "https://nvd.nist.gov/vuln/detail/CVE-2025-48951",
        "https://github.com/auth0/auth0-PHP/commit/04b1f5daa8bdfebc5e740ec5ca0fb2df1648a715"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-502"
        ],
        "cna_assigner": "GitHub_M",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/48xxx/CVE-2025-48951.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2025-48951",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 518379,
  "published_at": "2025-06-03T20:52:35.064+00:00"
}