Critical
Security advisory
In WordPress before 4.9.9 and 5.x before 5.0.1, contributors could conduct PHP object injection attacks via crafted metadata in a wp.getMediaItem XMLRPC call. This is caused by mishandling of serialized data at phar:// URLs in the wp_get_attachment_thumb_file function in wp-includes/post.php.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2018-20148
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 07:23 UTC · Revision 1
Source evidence
In WordPress before 4.9.9 and 5.x before 5.0.1, contributors could conduct PHP object injection attacks via crafted metadata in a wp.getMediaItem XMLRPC call. This is caused by mishandling of serialized data at phar:// URLs in the wp_get_attachment_thumb_file function in wp-includes/post.php.
osv:CVE-2018-20148
Complete source record
{
"id": "477c51848b27564823a53f3acb8724b67432b6ee27cda0ddedd2903b91a4991e",
"url": "https://osv.dev/vulnerability/CVE-2018-20148",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2018-20148",
"summary": "In WordPress before 4.9.9 and 5.x before 5.0.1, contributors could conduct PHP object injection attacks via crafted metadata in a wp.getMediaItem XMLRPC call. This is caused by mishandling of serialized data at phar:// URLs in the wp_get_attachment_thumb_file function in wp-includes/post.php.",
"evidence": "osv:CVE-2018-20148",
"products": [],
"severity": "critical",
"structured": {
"id": "CVE-2018-20148",
"aliases": [
"CVE-2018-20148"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/wordpress/wordpress",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "8d87e4a8b8aa7d66a4f5dd3795b5450fa0b76af0"
},
{
"introduced": "491c67be12ca8a9fe37ae38307ba7e298c976ec3"
},
{
"fixed": "3d448538caf519c6355bb32c0c8c21da87692855"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "4.9.9"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "5.0"
},
{
"fixed": "5.0.1"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"4.9.8"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2018-20148.json"
}
},
{
"ranges": [
{
"repo": "https://github.com/wordpress/wordpress-develop",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "a9ad836e97a736741122210792c64a6b2ed053ba"
},
{
"introduced": "b3bf6266acd61682bc654845f621b4426645e324"
},
{
"fixed": "53a3a5792edc4a55cbc81ebf084db08b93398f80"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "4.9.9"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "5.0"
},
{
"fixed": "5.0.1"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"4.9.8"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2018-20148.json"
}
}
],
"modified": "2026-10-24T10:30:52.544092063Z",
"provider": "osv",
"references": [
"https://codex.wordpress.org/Version_4.9.9",
"https://lists.debian.org/debian-lts-announce/2019/02/msg00019.html",
"https://wordpress.org/news/2018/12/wordpress-5-0-1-security-release/",
"https://wordpress.org/support/wordpress-version/version-5-0-1/",
"https://wpvulndb.com/vulnerabilities/9171",
"https://www.debian.org/security/2019/dsa-4401",
"https://www.zdnet.com/article/wordpress-plugs-bug-that-led-to-google-indexing-some-user-passwords/",
"https://www.zdnet.com/article/wordpress-vulnerability-affects-a-third-of-most-popular-websites-online/",
"https://blog.secarma.co.uk/labs/near-phar-dangerous-unserialization-wherever-you-are"
],
"provider_metadata": {
"unresolved_ranges": [
{
"cpes": [
"cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*",
"cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*"
],
"vendor_product": "debian:debian_linux",
"extracted_events": [
{
"range": [
{
"introduced": "8.0"
},
{
"last_affected": "8.0"
},
{
"introduced": "9.0"
},
{
"last_affected": "9.0"
}
],
"source": "CPE_STRING"
}
]
}
]
}
},
"related_cves": [
{
"value": "CVE-2018-20148",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 437729,
"published_at": "2018-12-14T20:29:00.39+00:00"
}