CriticalFix available
lua5.4 — security advisory
singlevar in lparser.c in Lua from (including) 5.4.0 up to (excluding) 5.4.4 lacks a certain luaK_exp2anyregup call, leading to a heap-based buffer over-read that might affect a system that compiles untrusted Lua code.
- Products
- lua5.4
- Affected versions
- Not specified
- Fixed versions
- 5.4.4-2
- CVEs
- CVE-2022-28805
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 30 Oct 2026, 14:48 UTC · Revision 1
Source evidence
singlevar in lparser.c in Lua from (including) 5.4.0 up to (excluding) 5.4.4 lacks a certain luaK_exp2anyregup call, leading to a heap-based buffer over-read that might affect a system that compiles untrusted Lua code.
osv:DEBIAN-CVE-2022-28805
lua5.4
Fixed versions: 5.4.4-2
lua5.4
Fixed versions: 5.4.4-2
lua5.4
Fixed versions: 5.4.4-2
Complete source record
{
"id": "d11b8402bcf95bc466f0f80e87c39ed6bcae1f1eabd095895599dca498bb77ba",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2022-28805",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2022-28805",
"summary": "singlevar in lparser.c in Lua from (including) 5.4.0 up to (excluding) 5.4.4 lacks a certain luaK_exp2anyregup call, leading to a heap-based buffer over-read that might affect a system that compiles untrusted Lua code.",
"evidence": "osv:DEBIAN-CVE-2022-28805",
"products": [
{
"name": {
"value": "lua5.4",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "5.4.4-2",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "lua5.4",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "5.4.4-2",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "lua5.4",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "5.4.4-2",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "critical",
"structured": {
"id": "DEBIAN-CVE-2022-28805",
"aliases": [
"DEBIAN-CVE-2022-28805"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "5.4.4-2"
}
]
}
],
"package": {
"name": "lua5.4",
"purl": "pkg:deb/debian/lua5.4?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-28805.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "5.4.4-2"
}
]
}
],
"package": {
"name": "lua5.4",
"purl": "pkg:deb/debian/lua5.4?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-28805.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "5.4.4-2"
}
]
}
],
"package": {
"name": "lua5.4",
"purl": "pkg:deb/debian/lua5.4?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-28805.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-15T08:02:22.896842953Z",
"provider": "osv",
"upstream": [
"CVE-2022-28805"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2022-28805"
]
},
"related_cves": [
{
"value": "CVE-2022-28805",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 323390,
"published_at": "2022-04-08T06:15:07.243+00:00"
}