ruby — security advisory
GitLab has remediated an issue in GitLab CE/EE affecting all versions from 19.2 before 19.2.8, 19.3 before 19.3.5, and 19.4 before 19.4.2 that, under certain conditions, could have allowed an unauthenticated user to execute arbitrary code on the GitLab server via a specially crafted regular expression in a CI/CD configuration, due to insufficient regular expression validation.
- Products
- ruby
- Affected versions
- Not specified
- Fixed versions
- 3.3.13-r0, 3.4.12-r0
- CVEs
- CVE-2026-97229
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 17:57 UTC · Revision 1
Source evidence
GitLab has remediated an issue in GitLab CE/EE affecting all versions from 19.2 before 19.2.8, 19.3 before 19.3.5, and 19.4 before 19.4.2 that, under certain conditions, could have allowed an unauthenticated user to execute arbitrary code on the GitLab server via a specially crafted regular expression in a CI/CD configuration, due to insufficient regular expression validation.
osv:ALPINE-CVE-2026-97229
ruby
Fixed versions: 3.3.13-r0
ruby
Fixed versions: 3.4.12-r0
ruby
Fixed versions: 3.4.12-r0
ruby
Fixed versions: 3.4.12-r0
Complete source record
{
"id": "3b0864333f16efa5dfe08f9835aa0b6a39af14686d567c307f7ef80a5b6eef0e",
"url": "https://osv.dev/vulnerability/ALPINE-CVE-2026-97229",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "ALPINE-CVE-2026-97229",
"summary": "GitLab has remediated an issue in GitLab CE/EE affecting all versions from 19.2 before 19.2.8, 19.3 before 19.3.5, and 19.4 before 19.4.2 that, under certain conditions, could have allowed an unauthenticated user to execute arbitrary code on the GitLab server via a specially crafted regular expression in a CI/CD configuration, due to insufficient regular expression validation.",
"evidence": "osv:ALPINE-CVE-2026-97229",
"products": [
{
"name": {
"value": "ruby",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.3.13-r0",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "ruby",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.4.12-r0",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "ruby",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.4.12-r0",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "ruby",
"evidence": "/affected/3/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.4.12-r0",
"evidence": "/affected/3/ranges"
}
],
"affected_versions": []
}
],
"severity": "critical",
"structured": {
"id": "ALPINE-CVE-2026-97229",
"aliases": [
"ALPINE-CVE-2026-97229"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.3.13-r0"
}
]
}
],
"package": {
"name": "ruby",
"purl": "pkg:apk/alpine/ruby?arch=source",
"ecosystem": "Alpine:v3.21"
},
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/alpine/ALPINE-CVE-2026-97229.json"
},
"ecosystem_specific": {}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.4.12-r0"
}
]
}
],
"package": {
"name": "ruby",
"purl": "pkg:apk/alpine/ruby?arch=source",
"ecosystem": "Alpine:v3.22"
},
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/alpine/ALPINE-CVE-2026-97229.json"
},
"ecosystem_specific": {}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.4.12-r0"
}
]
}
],
"package": {
"name": "ruby",
"purl": "pkg:apk/alpine/ruby?arch=source",
"ecosystem": "Alpine:v3.23"
},
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/alpine/ALPINE-CVE-2026-97229.json"
},
"ecosystem_specific": {}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.4.12-r0"
}
]
}
],
"package": {
"name": "ruby",
"purl": "pkg:apk/alpine/ruby?arch=source",
"ecosystem": "Alpine:v3.24"
},
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/alpine/ALPINE-CVE-2026-97229.json"
},
"ecosystem_specific": {}
}
],
"modified": "2026-10-27T12:30:04.242840155Z",
"provider": "osv",
"upstream": [
"CVE-2026-97229"
],
"references": [
"https://security.alpinelinux.org/vuln/CVE-2026-97229"
]
},
"related_cves": [
{
"value": "CVE-2026-97229",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 461541,
"published_at": "2026-10-13T02:17:00.84+00:00"
}