Skip to content
Heist/ feed
Back to feed
UnratedFix available

wordpress — security advisory

Type: advisorySources: OSVAdvisory ID: DEBIAN-CVE-2007-4894

Multiple SQL injection vulnerabilities in Wordpress before 2.2.3 and Wordpress multi-user (MU) before 1.2.5a allow remote attackers to execute arbitrary SQL commands via the post_type parameter to the pingback.extensions.getPingbacks method in the XMLRPC interface, and other unspecified parameters related to "early database escaping" and missing validation of "query string like parameters."

Products
wordpress
Affected versions
Not specified
Fixed versions
2.2.3-1
CVEs
CVE-2007-4894
Confirmed fixed CVEs
Not specified
Updated in this feed
31 Oct 2026, 15:44 UTC · Revision 1

Source evidence

DEBIAN-CVE-2007-4894

core-osv · Original source

Published 14 Sept 2007, 18:17 UTC

Multiple SQL injection vulnerabilities in Wordpress before 2.2.3 and Wordpress multi-user (MU) before 1.2.5a allow remote attackers to execute arbitrary SQL commands via the post_type parameter to the pingback.extensions.getPingbacks method in the XMLRPC interface, and other unspecified parameters related to "early database escaping" and missing validation of "query string like parameters."

osv:DEBIAN-CVE-2007-4894

wordpress

Fixed versions: 2.2.3-1

wordpress

Fixed versions: 2.2.3-1

wordpress

Fixed versions: 2.2.3-1

Complete source record
{
  "id": "2a56810bdf23d1b2cdf71580f70f2c4f3ebb093ade42704e2dc0a03423c81549",
  "url": "https://osv.dev/vulnerability/DEBIAN-CVE-2007-4894",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "DEBIAN-CVE-2007-4894",
    "summary": "Multiple SQL injection vulnerabilities in Wordpress before 2.2.3 and Wordpress multi-user (MU) before 1.2.5a allow remote attackers to execute arbitrary SQL commands via the post_type parameter to the pingback.extensions.getPingbacks method in the XMLRPC interface, and other unspecified parameters related to \"early database escaping\" and missing validation of \"query string like parameters.\"",
    "evidence": "osv:DEBIAN-CVE-2007-4894",
    "products": [
      {
        "name": {
          "value": "wordpress",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "2.2.3-1",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "wordpress",
          "evidence": "/affected/1/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "2.2.3-1",
            "evidence": "/affected/1/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "wordpress",
          "evidence": "/affected/2/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "2.2.3-1",
            "evidence": "/affected/2/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "unknown",
    "structured": {
      "id": "DEBIAN-CVE-2007-4894",
      "aliases": [
        "DEBIAN-CVE-2007-4894"
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "2.2.3-1"
                }
              ]
            }
          ],
          "package": {
            "name": "wordpress",
            "purl": "pkg:deb/debian/wordpress?arch=source&distro=bookworm",
            "ecosystem": "Debian:12"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2007-4894.json"
          },
          "ecosystem_specific": {
            "urgency": "medium"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "2.2.3-1"
                }
              ]
            }
          ],
          "package": {
            "name": "wordpress",
            "purl": "pkg:deb/debian/wordpress?arch=source&distro=trixie",
            "ecosystem": "Debian:13"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2007-4894.json"
          },
          "ecosystem_specific": {
            "urgency": "medium"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "2.2.3-1"
                }
              ]
            }
          ],
          "package": {
            "name": "wordpress",
            "purl": "pkg:deb/debian/wordpress?arch=source&distro=forky",
            "ecosystem": "Debian:14"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2007-4894.json"
          },
          "ecosystem_specific": {
            "urgency": "medium"
          }
        }
      ],
      "modified": "2026-10-21T17:47:31.291798761Z",
      "provider": "osv",
      "upstream": [
        "CVE-2007-4894"
      ],
      "references": [
        "https://security-tracker.debian.org/tracker/CVE-2007-4894"
      ]
    },
    "related_cves": [
      {
        "value": "CVE-2007-4894",
        "evidence": "/upstream"
      }
    ],
    "security_relevant": true,
    "severity_evidence": null
  },
  "source_id": "core-osv",
  "document_id": 398238,
  "published_at": "2007-09-14T18:17:00+00:00"
}