Security advisory
Multiple cross-site scripting (XSS) vulnerabilities in Papermerge before 1.5.2 allow remote attackers to inject arbitrary web script or HTML via the rename, tag, upload, or create folder function. The payload can be in a folder, a tag, or a document's filename. If email consumption is configured in Papermerge, a malicious document can be sent by email and is automatically uploaded into the Papermerge web application. Therefore, no authentication is required to exploit XSS if email consumption is configured. Otherwise authentication is required.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2020-29456
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 11:11 UTC · Revision 1
Source evidence
Multiple cross-site scripting (XSS) vulnerabilities in Papermerge before 1.5.2 allow remote attackers to inject arbitrary web script or HTML via the rename, tag, upload, or create folder function. The payload can be in a folder, a tag, or a document's filename. If email consumption is configured in Papermerge, a malicious document can be sent by email and is automatically uploaded into the Papermerge web application. Therefore, no authentication is required to exploit XSS if email consumption is configured. Otherwise authentication is required.
osv:CVE-2020-29456
Complete source record
{
"id": "e8c5aec207b31dfe39136f6499965fdf241c4a154ce3e4f2ddde5d61d71fe796",
"url": "https://osv.dev/vulnerability/CVE-2020-29456",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2020-29456",
"summary": "Multiple cross-site scripting (XSS) vulnerabilities in Papermerge before 1.5.2 allow remote attackers to inject arbitrary web script or HTML via the rename, tag, upload, or create folder function. The payload can be in a folder, a tag, or a document's filename. If email consumption is configured in Papermerge, a malicious document can be sent by email and is automatically uploaded into the Papermerge web application. Therefore, no authentication is required to exploit XSS if email consumption is configured. Otherwise authentication is required.",
"evidence": "osv:CVE-2020-29456",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2020-29456",
"aliases": [
"CVE-2020-29456",
"GHSA-9w49-m7xh-5r39",
"PYSEC-2020-74"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/ciur/papermerge",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "fd38288c9a7b271e33bbdb18794d3525ea78d964"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:papermerge:papermerge:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "1.5.2"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "fd38288c9a7b271e33bbdb18794d3525ea78d964"
}
],
"source": "REFERENCES_TAG",
"original_tag": "v1.5.2"
}
]
}
}
],
"versions": [
"v1.5.1",
"v1.5.0",
"v1.5.0.rc1",
"v1.4.1",
"v1.4.0",
"v1.4.0.rc3",
"v1.4.0.rc2",
"v1.4.0.rc1",
"v1.3.0",
"1.3.0",
"v1.3.0-alpha",
"v1.2.0",
"v1.2.1",
"v1.1.0",
"v1.0.0",
"1.0.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2020-29456.json"
}
}
],
"modified": "2026-10-20T10:53:14.606104809Z",
"provider": "osv",
"references": [
"https://www.papermerge.com/",
"https://github.com/ciur/papermerge/issues/228",
"https://github.com/ciur/papermerge/releases/tag/v1.5.2"
],
"provider_metadata": {}
},
"related_cves": [
{
"value": "CVE-2020-29456",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 384238,
"published_at": "2020-12-02T08:15:10.62+00:00"
}