High
TerriaJS-Server has a domain validation bypass vulnerability in its proxy allowlist
Type: advisorySources: OSV
TerriaJS-Server is a NodeJS Express server for TerriaJS, a library for building web-based geospatial data explorers. A validation bug in versions prior to 4.0.3 allows an attacker to proxy domains not explicitly allowed in the `proxyableDomains` configuration. Version 4.0.3 fixes the issue.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2026-27818
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 7 Nov 2026, 03:40 UTC · Revision 1
Source evidence
TerriaJS-Server has a domain validation bypass vulnerability in its proxy allowlist
core-osv · Original sourcePublished 26 Feb 2026, 00:02 UTC
TerriaJS-Server is a NodeJS Express server for TerriaJS, a library for building web-based geospatial data explorers. A validation bug in versions prior to 4.0.3 allows an attacker to proxy domains not explicitly allowed in the `proxyableDomains` configuration. Version 4.0.3 fixes the issue.
osv:CVE-2026-27818
Complete source record
{
"id": "d76568db967b4a50bc57052cc70a23a879e51cf1c5801e0042b7e831abd10a19",
"url": "https://osv.dev/vulnerability/CVE-2026-27818",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "TerriaJS-Server has a domain validation bypass vulnerability in its proxy allowlist",
"summary": "TerriaJS-Server is a NodeJS Express server for TerriaJS, a library for building web-based geospatial data explorers. A validation bug in versions prior to 4.0.3 allows an attacker to proxy domains not explicitly allowed in the `proxyableDomains` configuration. Version 4.0.3 fixes the issue.",
"evidence": "osv:CVE-2026-27818",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2026-27818",
"aliases": [
"CVE-2026-27818",
"GHSA-w789-49fc-v8hr"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/terriajs/terriajs-server",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "2689f9966c59bc28f9c4d27c49b4fd06a097dfc4"
},
{
"fixed": "3aaa5d9717162b245ae4569232bbe7d8673c913f"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:terria:terriajs-server:*:*:*:*:*:node.js:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "4.0.3"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "3aaa5d9717162b245ae4569232bbe7d8673c913f"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"4.0.2",
"4.0.1",
"4.0.0",
"3.3.4",
"3.3.3",
"3.3.1",
"3.3.0",
"3.2.0",
"3.1.0",
"3.0.1",
"3.0.0",
"2.9.2",
"2.9.1",
"2.9.0",
"2.8.0",
"2.7.3",
"2.7.2",
"2.7.1",
"2.7.0",
"2.6.7",
"2.6.6",
"2.6.5",
"2.6.4",
"2.6.3",
"2.6.2",
"2.6.1",
"2.6.0",
"2.5.1",
"2.5.0",
"2.4.0",
"2.3.0",
"2.2.2",
"2.2.1",
"2.2.0",
"2.0.0",
"2.1.0",
"1.4.1",
"1.4.0",
"v1.3.0",
"1.3.0",
"v1.2.0",
"1.2.0",
"v1.1.3",
"1.1.3",
"v1.1.2",
"1.1.2",
"v1.1.1",
"1.1.1",
"1.1.0",
"1.0.0",
"0.0.8"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-27818.json"
}
}
],
"modified": "2026-10-28T02:30:49.781975038Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/27xxx/CVE-2026-27818.json",
"https://github.com/TerriaJS/terriajs-server/security/advisories/GHSA-w789-49fc-v8hr",
"https://nvd.nist.gov/vuln/detail/CVE-2026-27818",
"https://github.com/TerriaJS/terriajs-server/commit/3aaa5d9717162b245ae4569232bbe7d8673c913f"
],
"provider_metadata": {
"cwe_ids": [
"CWE-20",
"CWE-918"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/27xxx/CVE-2026-27818.json"
}
},
"related_cves": [
{
"value": "CVE-2026-27818",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 517829,
"published_at": "2026-02-26T00:02:45.127+00:00"
}