Skip to content
Heist/ feed
Back to feed
CriticalFix available

wolfssl — security advisory

Type: advisorySources: OSVAdvisory ID: DEBIAN-CVE-2022-23408

wolfSSL 5.x before 5.1.1 uses non-random IV values in certain situations. This affects connections (without AEAD) using AES-CBC or DES3 with TLS 1.1 or 1.2 or DTLS 1.1 or 1.2. This occurs because of misplaced memory initialization in BuildMessage in internal.c.

Products
wolfssl
Affected versions
Not specified
Fixed versions
5.1.1-1
CVEs
CVE-2022-23408
Confirmed fixed CVEs
Not specified
Updated in this feed
30 Oct 2026, 14:47 UTC · Revision 1

Source evidence

DEBIAN-CVE-2022-23408

core-osv · Original source

Published 18 Jan 2022, 21:15 UTC

wolfSSL 5.x before 5.1.1 uses non-random IV values in certain situations. This affects connections (without AEAD) using AES-CBC or DES3 with TLS 1.1 or 1.2 or DTLS 1.1 or 1.2. This occurs because of misplaced memory initialization in BuildMessage in internal.c.

osv:DEBIAN-CVE-2022-23408

wolfssl

Fixed versions: 5.1.1-1

wolfssl

Fixed versions: 5.1.1-1

Complete source record
{
  "id": "349fa76ab5826d6eb9a55b2496793b78bae63a0ed4a93343830ebced5a45386c",
  "url": "https://osv.dev/vulnerability/DEBIAN-CVE-2022-23408",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "DEBIAN-CVE-2022-23408",
    "summary": "wolfSSL 5.x before 5.1.1 uses non-random IV values in certain situations. This affects connections (without AEAD) using AES-CBC or DES3 with TLS 1.1 or 1.2 or DTLS 1.1 or 1.2. This occurs because of misplaced memory initialization in BuildMessage in internal.c.",
    "evidence": "osv:DEBIAN-CVE-2022-23408",
    "products": [
      {
        "name": {
          "value": "wolfssl",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "5.1.1-1",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "wolfssl",
          "evidence": "/affected/1/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "5.1.1-1",
            "evidence": "/affected/1/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "critical",
    "structured": {
      "id": "DEBIAN-CVE-2022-23408",
      "aliases": [
        "DEBIAN-CVE-2022-23408"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "5.1.1-1"
                }
              ]
            }
          ],
          "package": {
            "name": "wolfssl",
            "purl": "pkg:deb/debian/wolfssl?arch=source&distro=bookworm",
            "ecosystem": "Debian:12"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-23408.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "5.1.1-1"
                }
              ]
            }
          ],
          "package": {
            "name": "wolfssl",
            "purl": "pkg:deb/debian/wolfssl?arch=source&distro=trixie",
            "ecosystem": "Debian:13"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-23408.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        }
      ],
      "modified": "2026-10-15T08:02:08.657333975Z",
      "provider": "osv",
      "upstream": [
        "CVE-2022-23408"
      ],
      "references": [
        "https://security-tracker.debian.org/tracker/CVE-2022-23408"
      ]
    },
    "related_cves": [
      {
        "value": "CVE-2022-23408",
        "evidence": "/upstream"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 323280,
  "published_at": "2022-01-18T21:15:07.863+00:00"
}