HighFix available
ghostscript — security advisory
In Artifex Ghostscript before 9.24, attackers able to supply crafted PostScript files could use a type confusion in the LockDistillerParams parameter to crash the interpreter or execute code.
- Products
- ghostscript
- Affected versions
- Not specified
- Fixed versions
- 9.22~dfsg-3
- CVEs
- CVE-2018-15910
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 00:07 UTC · Revision 1
Source evidence
In Artifex Ghostscript before 9.24, attackers able to supply crafted PostScript files could use a type confusion in the LockDistillerParams parameter to crash the interpreter or execute code.
osv:DEBIAN-CVE-2018-15910
ghostscript
Fixed versions: 9.22~dfsg-3
ghostscript
Fixed versions: 9.22~dfsg-3
ghostscript
Fixed versions: 9.22~dfsg-3
Complete source record
{
"id": "9f3ef82d2c49efc4547da51dd794cb49ece57e9c011fd52b26968b09e7e3dd7b",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2018-15910",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2018-15910",
"summary": "In Artifex Ghostscript before 9.24, attackers able to supply crafted PostScript files could use a type confusion in the LockDistillerParams parameter to crash the interpreter or execute code.",
"evidence": "osv:DEBIAN-CVE-2018-15910",
"products": [
{
"name": {
"value": "ghostscript",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "9.22~dfsg-3",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "ghostscript",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "9.22~dfsg-3",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "ghostscript",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "9.22~dfsg-3",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2018-15910",
"aliases": [
"DEBIAN-CVE-2018-15910"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "9.22~dfsg-3"
}
]
}
],
"package": {
"name": "ghostscript",
"purl": "pkg:deb/debian/ghostscript?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2018-15910.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "9.22~dfsg-3"
}
]
}
],
"package": {
"name": "ghostscript",
"purl": "pkg:deb/debian/ghostscript?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2018-15910.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "9.22~dfsg-3"
}
]
}
],
"package": {
"name": "ghostscript",
"purl": "pkg:deb/debian/ghostscript?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2018-15910.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-23T18:03:00.269170680Z",
"provider": "osv",
"upstream": [
"CVE-2018-15910"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2018-15910"
]
},
"related_cves": [
{
"value": "CVE-2018-15910",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 420072,
"published_at": "2018-08-27T17:29:00.547+00:00"
}