vega.js — security advisory
Vega is a visualization grammar, a declarative format for creating, saving, and sharing interactive visualization designs. In `vega` 5.30.0 and lower and in `vega-functions` 5.15.0 and lower , it was possible to call JavaScript functions from the Vega expression language that were not meant to be supported. The issue is patched in `vega` `5.31.0` and `vega-functions` `5.16.0`. Some workarounds are available. Run `vega` without `vega.expressionInterpreter`. This mode is not the default as it is slower. Alternatively, using the interpreter described in CSP safe mode (Content Security Policy) prevents arbitrary Javascript from running, so users of this mode are not affected by this vulnerability.
- Products
- vega.js
- Affected versions
- 5.25.0+ds+~cs5.3.0-2, 5.25.0+ds+~cs5.3.0-5, 5.28.0+ds+~cs5.3.0-1, 5.28.0+ds+~cs5.3.0-2, 5.33.1+ds+~cs5.3.0-4
- Fixed versions
- Not specified
- CVEs
- CVE-2025-26619
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 01:47 UTC · Revision 1
Source evidence
Vega is a visualization grammar, a declarative format for creating, saving, and sharing interactive visualization designs. In `vega` 5.30.0 and lower and in `vega-functions` 5.15.0 and lower , it was possible to call JavaScript functions from the Vega expression language that were not meant to be supported. The issue is patched in `vega` `5.31.0` and `vega-functions` `5.16.0`. Some workarounds are available. Run `vega` without `vega.expressionInterpreter`. This mode is not the default as it is slower. Alternatively, using the interpreter described in CSP safe mode (Content Security Policy) prevents arbitrary Javascript from running, so users of this mode are not affected by this vulnerability.
osv:UBUNTU-CVE-2025-26619
vega.js
Fixed versions: Not specified
vega.js
Fixed versions: Not specified
vega.js
Fixed versions: Not specified
vega.js
Fixed versions: Not specified
Complete source record
{
"id": "2e78273c22ea5772d59303887dae96bff11d62192130209765b6c5e27246b8ee",
"url": "https://osv.dev/vulnerability/UBUNTU-CVE-2025-26619",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "UBUNTU-CVE-2025-26619",
"summary": "Vega is a visualization grammar, a declarative format for creating, saving, and sharing interactive visualization designs. In `vega` 5.30.0 and lower and in `vega-functions` 5.15.0 and lower , it was possible to call JavaScript functions from the Vega expression language that were not meant to be supported. The issue is patched in `vega` `5.31.0` and `vega-functions` `5.16.0`. Some workarounds are available. Run `vega` without `vega.expressionInterpreter`. This mode is not the default as it is slower. Alternatively, using the interpreter described in CSP safe mode (Content Security Policy) prevents arbitrary Javascript from running, so users of this mode are not affected by this vulnerability.",
"evidence": "osv:UBUNTU-CVE-2025-26619",
"products": [
{
"name": {
"value": "vega.js",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "5.25.0+ds+~cs5.3.0-2",
"evidence": "/affected/0/versions"
},
{
"value": "5.25.0+ds+~cs5.3.0-5",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "vega.js",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "5.28.0+ds+~cs5.3.0-1",
"evidence": "/affected/1/versions"
}
]
},
{
"name": {
"value": "vega.js",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "5.28.0+ds+~cs5.3.0-2",
"evidence": "/affected/2/versions"
},
{
"value": "5.33.1+ds+~cs5.3.0-4",
"evidence": "/affected/2/versions"
}
]
},
{
"name": {
"value": "vega.js",
"evidence": "/affected/3/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "5.28.0+ds+~cs5.3.0-1",
"evidence": "/affected/3/versions"
},
{
"value": "5.28.0+ds+~cs5.3.0-2",
"evidence": "/affected/3/versions"
}
]
}
],
"severity": "medium",
"structured": {
"id": "UBUNTU-CVE-2025-26619",
"aliases": [
"UBUNTU-CVE-2025-26619"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N"
},
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N"
},
{
"type": "Ubuntu",
"score": "medium"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "vega.js",
"purl": "pkg:deb/ubuntu/vega.js?arch=source&distro=noble",
"ecosystem": "Ubuntu:24.04:LTS"
},
"versions": [
"5.25.0+ds+~cs5.3.0-2",
"5.25.0+ds+~cs5.3.0-5"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2025/UBUNTU-CVE-2025-26619.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "libjs-vega",
"binary_version": "5.25.0+ds+~cs5.3.0-5"
},
{
"binary_name": "node-vega",
"binary_version": "5.25.0+ds+~cs5.3.0-5"
}
]
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "vega.js",
"purl": "pkg:deb/ubuntu/vega.js?arch=source&distro=questing",
"ecosystem": "Ubuntu:25.10"
},
"versions": [
"5.28.0+ds+~cs5.3.0-1"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2025/UBUNTU-CVE-2025-26619.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "libjs-vega",
"binary_version": "5.28.0+ds+~cs5.3.0-1"
},
{
"binary_name": "node-vega",
"binary_version": "5.28.0+ds+~cs5.3.0-1"
}
]
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "vega.js",
"purl": "pkg:deb/ubuntu/vega.js?arch=source&distro=stonking",
"ecosystem": "Ubuntu:26.10"
},
"versions": [
"5.28.0+ds+~cs5.3.0-2",
"5.33.1+ds+~cs5.3.0-4"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2025/UBUNTU-CVE-2025-26619.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "libjs-vega",
"binary_version": "5.33.1+ds+~cs5.3.0-4"
},
{
"binary_name": "node-vega",
"binary_version": "5.33.1+ds+~cs5.3.0-4"
}
]
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "vega.js",
"purl": "pkg:deb/ubuntu/vega.js?arch=source&distro=resolute",
"ecosystem": "Ubuntu:26.04:LTS"
},
"versions": [
"5.28.0+ds+~cs5.3.0-1",
"5.28.0+ds+~cs5.3.0-2"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2025/UBUNTU-CVE-2025-26619.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "libjs-vega",
"binary_version": "5.28.0+ds+~cs5.3.0-2"
},
{
"binary_name": "node-vega",
"binary_version": "5.28.0+ds+~cs5.3.0-2"
}
]
}
}
],
"modified": "2026-10-17T12:57:26.979017951Z",
"provider": "osv",
"upstream": [
"CVE-2025-26619"
],
"references": [
"https://ubuntu.com/security/CVE-2025-26619",
"https://www.cve.org/CVERecord?id=CVE-2025-26619",
"https://github.com/vega/vega/commit/8fc129a6f8a11e96449c4ac0f63de0e5bfc7254c",
"https://github.com/vega/vega/issues/3984",
"https://github.com/vega/vega/security/advisories/GHSA-rcw3-wmx7-cphr",
"https://github.com/vega/vega-lite/issues/9469"
]
},
"related_cves": [
{
"value": "CVE-2025-26619",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 357502,
"published_at": "2025-03-27T14:15:00+00:00"
}