Medium
Security advisory
It was found that wolfssl before 3.15.7 is vulnerable to a new variant of the Bleichenbacher attack to perform downgrade attacks against TLS. This may lead to leakage of sensible data.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2018-16870
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 10:04 UTC · Revision 1
Source evidence
It was found that wolfssl before 3.15.7 is vulnerable to a new variant of the Bleichenbacher attack to perform downgrade attacks against TLS. This may lead to leakage of sensible data.
osv:CVE-2018-16870
Complete source record
{
"id": "83750c88595d8e0fa58a531450329594b47f1ec35c73ee0029c7960085262b9e",
"url": "https://osv.dev/vulnerability/CVE-2018-16870",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2018-16870",
"summary": "It was found that wolfssl before 3.15.7 is vulnerable to a new variant of the Bleichenbacher attack to perform downgrade attacks against TLS. This may lead to leakage of sensible data.",
"evidence": "osv:CVE-2018-16870",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2018-16870",
"aliases": [
"CVE-2018-16870"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/wolfssl/wolfssl",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "a7350b7d2ed15648443253cb39ad9195df184139"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:wolfssl:wolfssl:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "3.15.7"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v3.15.6",
"v3.15.5a",
"v3.15.5-stable",
"WCv4-rng-stable",
"v3.15.3-stable",
"l",
"v3.15.0-stable",
"v3.14.4",
"v3.14.2",
"v3.14.0b",
"v3.14.0a",
"v3.14.0-stable",
"v3.13.3",
"v3.13.2",
"v3.13.0-stable",
"v3.12.2-stable",
"v3.12.0-stable",
"v3.11.1-tls13-beta",
"v3.11.0-stable",
"v3.10.3",
"v3.10.2-stable",
"v3.10.0a",
"v3.10.0-stable",
"v3.9.10b",
"v3.9.10-stable",
"v3.9.8",
"v3.9.6w",
"v3.9.6",
"v3.9.1",
"v3.9.0",
"v3.8.0",
"v3.7.3",
"v3.7.1",
"v3.7.0",
"v3.6.9",
"v3.6.8",
"v3.4.6",
"v3.4.2",
"v3.4.0",
"v3.3.3",
"v3.3.0",
"v3.2.6",
"v3.2.4",
"v3.2.0",
"v2.9.4",
"v2.9.2",
"v2.9.1",
"v0.5",
"v2.9.0",
"v2.8.6",
"v2.8.5a",
"v2.8.5",
"v2.8.4",
"v2.8.3",
"v2.8.2",
"v2.8.0",
"v2.7.2",
"v2.7.0",
"v2.6.2",
"v2.6.0",
"v2.4.7",
"v2.4.6",
"v2.4.2",
"v2.0.8",
"v2.0.6",
"v2.0.3",
"v2.0.2",
"v2.0rc3",
"v2.0rc2b",
"v2.0rc2",
"v2.0rc1",
"v1.9.0",
"v1.8.8.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2018-16870.json"
}
}
],
"modified": "2026-10-20T10:49:52.182637077Z",
"provider": "osv",
"references": [
"https://github.com/wolfSSL/wolfssl/pull/1950"
],
"provider_metadata": {}
},
"related_cves": [
{
"value": "CVE-2018-16870",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 380892,
"published_at": "2019-01-03T16:29:00.227+00:00"
}