UnratedFix available
phpmyadmin — security advisory
Cross-site scripting (XSS) vulnerability in libraries/config/ConfigFile.class.php in the setup interface in phpMyAdmin 3.4.x before 3.4.9 allows remote attackers to inject arbitrary web script or HTML via the host parameter.
- Products
- phpmyadmin
- Affected versions
- Not specified
- Fixed versions
- 4:3.4.9-1
- CVEs
- CVE-2011-4782
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 22:56 UTC · Revision 1
Source evidence
Cross-site scripting (XSS) vulnerability in libraries/config/ConfigFile.class.php in the setup interface in phpMyAdmin 3.4.x before 3.4.9 allows remote attackers to inject arbitrary web script or HTML via the host parameter.
osv:DEBIAN-CVE-2011-4782
phpmyadmin
Fixed versions: 4:3.4.9-1
phpmyadmin
Fixed versions: 4:3.4.9-1
phpmyadmin
Fixed versions: 4:3.4.9-1
Complete source record
{
"id": "bb3d5da044726b402b02c033451da5fca805cba874933e646c0b3099cb7131c6",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2011-4782",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2011-4782",
"summary": "Cross-site scripting (XSS) vulnerability in libraries/config/ConfigFile.class.php in the setup interface in phpMyAdmin 3.4.x before 3.4.9 allows remote attackers to inject arbitrary web script or HTML via the host parameter.",
"evidence": "osv:DEBIAN-CVE-2011-4782",
"products": [
{
"name": {
"value": "phpmyadmin",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "4:3.4.9-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "phpmyadmin",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "4:3.4.9-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "phpmyadmin",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "4:3.4.9-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "unknown",
"structured": {
"id": "DEBIAN-CVE-2011-4782",
"aliases": [
"DEBIAN-CVE-2011-4782"
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "4:3.4.9-1"
}
]
}
],
"package": {
"name": "phpmyadmin",
"purl": "pkg:deb/debian/phpmyadmin?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2011-4782.json"
},
"ecosystem_specific": {
"urgency": "unimportant"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "4:3.4.9-1"
}
]
}
],
"package": {
"name": "phpmyadmin",
"purl": "pkg:deb/debian/phpmyadmin?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2011-4782.json"
},
"ecosystem_specific": {
"urgency": "unimportant"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "4:3.4.9-1"
}
]
}
],
"package": {
"name": "phpmyadmin",
"purl": "pkg:deb/debian/phpmyadmin?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2011-4782.json"
},
"ecosystem_specific": {
"urgency": "unimportant"
}
}
],
"modified": "2026-10-23T17:47:29.988179869Z",
"provider": "osv",
"upstream": [
"CVE-2011-4782"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2011-4782"
]
},
"related_cves": [
{
"value": "CVE-2011-4782",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": null
},
"source_id": "core-osv",
"document_id": 417264,
"published_at": "2011-12-22T20:55:01.03+00:00"
}