UnratedFix available
poppler — security advisory
The JBIG2Stream::readSymbolDictSeg function in Poppler before 0.10.4 allows remote attackers to cause a denial of service (crash) via a PDF file that triggers a parsing error, which is not properly handled by JBIG2SymbolDict::~JBIG2SymbolDict and triggers an invalid memory dereference.
- Products
- poppler
- Affected versions
- Not specified
- Fixed versions
- 0.10.6-1
- CVEs
- CVE-2009-0756
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 22:46 UTC · Revision 1
Source evidence
The JBIG2Stream::readSymbolDictSeg function in Poppler before 0.10.4 allows remote attackers to cause a denial of service (crash) via a PDF file that triggers a parsing error, which is not properly handled by JBIG2SymbolDict::~JBIG2SymbolDict and triggers an invalid memory dereference.
osv:DEBIAN-CVE-2009-0756
poppler
Fixed versions: 0.10.6-1
poppler
Fixed versions: 0.10.6-1
poppler
Fixed versions: 0.10.6-1
Complete source record
{
"id": "6cf167a2b43843e4f6b55c112d9c55a8390e1c5e46095093e14d8a7bf2c2a3ce",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2009-0756",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2009-0756",
"summary": "The JBIG2Stream::readSymbolDictSeg function in Poppler before 0.10.4 allows remote attackers to cause a denial of service (crash) via a PDF file that triggers a parsing error, which is not properly handled by JBIG2SymbolDict::~JBIG2SymbolDict and triggers an invalid memory dereference.",
"evidence": "osv:DEBIAN-CVE-2009-0756",
"products": [
{
"name": {
"value": "poppler",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "0.10.6-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "poppler",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "0.10.6-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "poppler",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "0.10.6-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "unknown",
"structured": {
"id": "DEBIAN-CVE-2009-0756",
"aliases": [
"DEBIAN-CVE-2009-0756"
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "0.10.6-1"
}
]
}
],
"package": {
"name": "poppler",
"purl": "pkg:deb/debian/poppler?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2009-0756.json"
},
"ecosystem_specific": {
"urgency": "low"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "0.10.6-1"
}
]
}
],
"package": {
"name": "poppler",
"purl": "pkg:deb/debian/poppler?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2009-0756.json"
},
"ecosystem_specific": {
"urgency": "low"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "0.10.6-1"
}
]
}
],
"package": {
"name": "poppler",
"purl": "pkg:deb/debian/poppler?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2009-0756.json"
},
"ecosystem_specific": {
"urgency": "low"
}
}
],
"modified": "2026-10-23T17:47:29.251652841Z",
"provider": "osv",
"upstream": [
"CVE-2009-0756"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2009-0756"
]
},
"related_cves": [
{
"value": "CVE-2009-0756",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": null
},
"source_id": "core-osv",
"document_id": 417196,
"published_at": "2009-03-03T16:30:05.267+00:00"
}