Skip to content
Heist/ feed
Back to feed
Medium

YesWiki Vulnerable to Stored XSS in Comments

Type: advisorySources: OSV

YesWiki is a wiki system written in PHP. Prior to version 4.5.4, a stored cross-site scripting (XSS) vulnerability was discovered in the application’s comments feature. This issue allows a malicious actor to inject JavaScript payloads that are stored and later executed in the browser of any user viewing the affected comment. The XSS occurs because the application fails to properly sanitize or encode user input submitted to the comments. Notably, the application sanitizes or does not allow execution of `

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2025-46346
Confirmed fixed CVEs
Not specified
Updated in this feed
3 Nov 2026, 18:27 UTC · Revision 1

Source evidence

YesWiki Vulnerable to Stored XSS in Comments

core-osv · Original source

Published 29 Apr 2025, 15:36 UTC

YesWiki is a wiki system written in PHP. Prior to version 4.5.4, a stored cross-site scripting (XSS) vulnerability was discovered in the application’s comments feature. This issue allows a malicious actor to inject JavaScript payloads that are stored and later executed in the browser of any user viewing the affected comment. The XSS occurs because the application fails to properly sanitize or encode user input submitted to the comments. Notably, the application sanitizes or does not allow execution of `

osv:CVE-2025-46346
Complete source record
{
  "id": "f023d7a692c8cd3be61992c08fd5562c2de11b9306263704dfebea44c09bde65",
  "url": "https://osv.dev/vulnerability/CVE-2025-46346",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "YesWiki Vulnerable to Stored XSS in Comments",
    "summary": "YesWiki is a wiki system written in PHP. Prior to version 4.5.4, a stored cross-site scripting (XSS) vulnerability was discovered in the application’s comments feature. This issue allows a malicious actor to inject JavaScript payloads that are stored and later executed in the browser of any user viewing the affected comment. The XSS occurs because the application fails to properly sanitize or encode user input submitted to the comments. Notably, the application sanitizes or does not allow execution of `",
    "evidence": "osv:CVE-2025-46346",
    "products": [],
    "severity": "medium",
    "structured": {
      "id": "CVE-2025-46346",
      "aliases": [
        "CVE-2025-46346",
        "GHSA-59x8-cvxh-3mm4"
      ],
      "metrics": [
        {
          "type": "CVSS_V4",
          "score": "CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:N/SI:H/SA:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/yeswiki/yeswiki",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "4e9e51d80cd024ed2ac5c12c820817e6d8c2655a"
                },
                {
                  "fixed": "0d4efc880a727599fa4f6d7a64cc967afe475530"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:yeswiki:yeswiki:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "4.5.4"
                      }
                    ],
                    "source": "CPE_RANGE"
                  },
                  {
                    "range": [
                      {
                        "fixed": "0d4efc880a727599fa4f6d7a64cc967afe475530"
                      }
                    ],
                    "source": "REFERENCES_COMMIT"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v4.5.3",
            "v4.5.2",
            "v4.5.1",
            "v4.4.3",
            "v4.4.2",
            "v4.4.1",
            "v4.4.0",
            "v4.3.1",
            "v4.3.0",
            "v4.2.2",
            "v4.2.1",
            "v4.2.0",
            "v4.1.5",
            "v4.1.0"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-46346.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:31.468491246Z",
      "provider": "osv",
      "references": [
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/46xxx/CVE-2025-46346.json",
        "https://github.com/YesWiki/yeswiki/security/advisories/GHSA-59x8-cvxh-3mm4",
        "https://nvd.nist.gov/vuln/detail/CVE-2025-46346",
        "https://github.com/YesWiki/yeswiki/commit/0d4efc880a727599fa4f6d7a64cc967afe475530"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-79"
        ],
        "cna_assigner": "GitHub_M",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/46xxx/CVE-2025-46346.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2025-46346",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 498434,
  "published_at": "2025-04-29T15:36:14.321+00:00"
}