Critical
Security advisory
This affects the package dotty before 0.1.2. A type confusion vulnerability can lead to a bypass of CVE-2021-25912 when the user-provided keys used in the path parameter are arrays.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2021-23624
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 11:40 UTC · Revision 1
Source evidence
This affects the package dotty before 0.1.2. A type confusion vulnerability can lead to a bypass of CVE-2021-25912 when the user-provided keys used in the path parameter are arrays.
osv:CVE-2021-23624
Complete source record
{
"id": "c3843c732c8aae14bc5ce732d84fe477011a89ef930ee759a9a845f3341d2588",
"url": "https://osv.dev/vulnerability/CVE-2021-23624",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2021-23624",
"summary": "This affects the package dotty before 0.1.2. A type confusion vulnerability can lead to a bypass of CVE-2021-25912 when the user-provided keys used in the path parameter are arrays.",
"evidence": "osv:CVE-2021-23624",
"products": [],
"severity": "critical",
"structured": {
"id": "CVE-2021-23624",
"aliases": [
"CVE-2021-23624",
"GHSA-6g47-63mv-qpgh",
"SNYK-JS-DOTTY-1577292"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/deoxxa/dotty",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "88f61860dcc274a07a263c32cbe9d44c24ef02d7"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"fixed": "88f61860dcc274a07a263c32cbe9d44c24ef02d7"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"v0.1.1",
"v0.1.0",
"0.0.2"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2021-23624.json"
}
}
],
"modified": "2026-10-20T10:54:32.600674924Z",
"provider": "osv",
"references": [
"https://github.com/deoxxa/dotty/commit/88f61860dcc274a07a263c32cbe9d44c24ef02d7",
"https://snyk.io/vuln/SNYK-JS-DOTTY-1577292"
],
"provider_metadata": {
"unresolved_ranges": [
{
"cpes": [
"cpe:2.3:a:dotty_project:dotty:*:*:*:*:*:*:*:*"
],
"vendor_product": "dotty_project:dotty",
"extracted_events": [
{
"range": [
{
"fixed": "0.1.2"
}
],
"source": "CPE_RANGE"
}
]
},
{
"extracted_events": [
{
"range": [
{
"fixed": "0.1.2"
}
],
"source": "DESCRIPTION"
}
]
}
]
}
},
"related_cves": [
{
"value": "CVE-2021-23624",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 385534,
"published_at": "2021-11-03T18:15:08.13+00:00"
}