UnratedFix available
gpgme1.0 — security advisory
Multiple heap-based buffer overflows in the status_handler function in (1) engine-gpgsm.c and (2) engine-uiserver.c in GPGME before 1.5.1 allow remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via vectors related to "different line lengths in a specific order."
- Products
- gpgme1.0
- Affected versions
- Not specified
- Fixed versions
- 1.5.1-1
- CVEs
- CVE-2014-3564
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 21:42 UTC · Revision 1
Source evidence
Multiple heap-based buffer overflows in the status_handler function in (1) engine-gpgsm.c and (2) engine-uiserver.c in GPGME before 1.5.1 allow remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via vectors related to "different line lengths in a specific order."
osv:DEBIAN-CVE-2014-3564
gpgme1.0
Fixed versions: 1.5.1-1
gpgme1.0
Fixed versions: 1.5.1-1
gpgme1.0
Fixed versions: 1.5.1-1
Complete source record
{
"id": "5368a13aa11777d32980a85be201f6b93b58d0449ac592ed00a6c75766e7a343",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2014-3564",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2014-3564",
"summary": "Multiple heap-based buffer overflows in the status_handler function in (1) engine-gpgsm.c and (2) engine-uiserver.c in GPGME before 1.5.1 allow remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via vectors related to \"different line lengths in a specific order.\"",
"evidence": "osv:DEBIAN-CVE-2014-3564",
"products": [
{
"name": {
"value": "gpgme1.0",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.5.1-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "gpgme1.0",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.5.1-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "gpgme1.0",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.5.1-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "unknown",
"structured": {
"id": "DEBIAN-CVE-2014-3564",
"aliases": [
"DEBIAN-CVE-2014-3564"
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.5.1-1"
}
]
}
],
"package": {
"name": "gpgme1.0",
"purl": "pkg:deb/debian/gpgme1.0?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2014-3564.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.5.1-1"
}
]
}
],
"package": {
"name": "gpgme1.0",
"purl": "pkg:deb/debian/gpgme1.0?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2014-3564.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.5.1-1"
}
]
}
],
"package": {
"name": "gpgme1.0",
"purl": "pkg:deb/debian/gpgme1.0?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2014-3564.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-23T15:47:32.531164689Z",
"provider": "osv",
"upstream": [
"CVE-2014-3564"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2014-3564"
]
},
"related_cves": [
{
"value": "CVE-2014-3564",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": null
},
"source_id": "core-osv",
"document_id": 414183,
"published_at": "2014-10-20T17:55:05.383+00:00"
}