Medium
Security advisory
Versions of the package nice-select2 before 2.4.1 are vulnerable to Cross-site Scripting (XSS) via the element. An attacker can supply a malicious payload that is rendered directly into the DOM without proper sanitization, causing arbitrary script execution in a victim’s browser when they view or interact with the affected page.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2026-17528
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 3 Nov 2026, 01:12 UTC · Revision 1
Source evidence
Versions of the package nice-select2 before 2.4.1 are vulnerable to Cross-site Scripting (XSS) via the element. An attacker can supply a malicious payload that is rendered directly into the DOM without proper sanitization, causing arbitrary script execution in a victim’s browser when they view or interact with the affected page.
osv:CVE-2026-17528
Complete source record
{
"id": "9c732be831317f770c098145849cf6e5fece268d90499c08f73620e9173def9e",
"url": "https://osv.dev/vulnerability/CVE-2026-17528",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2026-17528",
"summary": "Versions of the package nice-select2 before 2.4.1 are vulnerable to Cross-site Scripting (XSS) via the element. An attacker can supply a malicious payload that is rendered directly into the DOM without proper sanitization, causing arbitrary script execution in a victim’s browser when they view or interact with the affected page.",
"evidence": "osv:CVE-2026-17528",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2026-17528",
"aliases": [
"CVE-2026-17528"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:L/VA:N/SC:L/SI:L/SA:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/bluzky/nice-select2",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "7dc5aca1dff0b6bd976f01378601a5e628eeaba3"
},
{
"fixed": "ea23ff404e186f6e2a64a25c530f93165fd2ad26"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "0"
},
{
"fixed": "2.4.1"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
},
{
"range": [
{
"fixed": "ea23ff404e186f6e2a64a25c530f93165fd2ad26"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"2.4.0",
"2.3.1",
"v2.1.0",
"v2.0.0",
"v1.0.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-17528.json"
}
}
],
"modified": "2026-10-28T02:30:24.837862705Z",
"provider": "osv",
"references": [
"https://security.snyk.io/vuln/SNYK-JS-NICESELECT2-13638683",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/17xxx/CVE-2026-17528.json",
"https://nvd.nist.gov/vuln/detail/CVE-2026-17528",
"https://github.com/bluzky/nice-select2/issues/97",
"https://github.com/bluzky/nice-select2/commit/ea23ff404e186f6e2a64a25c530f93165fd2ad26"
],
"provider_metadata": {
"cwe_ids": [
"CWE-79"
],
"cna_assigner": "snyk",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/17xxx/CVE-2026-17528.json"
}
},
"related_cves": [
{
"value": "CVE-2026-17528",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 491466,
"published_at": "2026-07-28T05:00:01.62+00:00"
}