Skip to content
Heist/ feed
Back to feed
LowFix available

Apache APISIX: session fixation issue in feishu-auth and dingtalk-auth plugin

Type: advisorySources: OSV

Cross-Site request forgery (CSRF) vulnerability in feishu-auth and dingtalk-auth plugins in Apache APISIX. An attacker who can get a user to click a crafted link may cause that user's browser session on a protected route to be established under the attacker's identity instead of their own. Any work the user then performs in that session, including uploads, form submissions, and account bindings, lands in the attacker's account. This issue affects Apache APISIX: from 3.17.0 through 3.18.0. Users are recommended to upgrade to version 3.19.0, which fixes the issue.

Products
apisix
Affected versions
Not specified
Fixed versions
3.19.0
CVEs
CVE-2026-94220
Confirmed fixed CVEs
Not specified
Updated in this feed
28 Oct 2026, 12:32 UTC · Revision 1

Source evidence

Apache APISIX: session fixation issue in feishu-auth and dingtalk-auth plugin

core-osv · Original source

Published 9 Oct 2026, 10:43 UTC

Cross-Site request forgery (CSRF) vulnerability in feishu-auth and dingtalk-auth plugins in Apache APISIX. An attacker who can get a user to click a crafted link may cause that user's browser session on a protected route to be established under the attacker's identity instead of their own. Any work the user then performs in that session, including uploads, form submissions, and account bindings, lands in the attacker's account. This issue affects Apache APISIX: from 3.17.0 through 3.18.0. Users are recommended to upgrade to version 3.19.0, which fixes the issue.

osv:BIT-apisix-2026-94220

apisix

Fixed versions: 3.19.0

Complete source record
{
  "id": "e6a995683b084377529b7e3d8106cf30c232fa8eb71e2237cfe5e9862044250e",
  "url": "https://osv.dev/vulnerability/BIT-apisix-2026-94220",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "Apache APISIX: session fixation issue in feishu-auth and dingtalk-auth plugin",
    "summary": "Cross-Site request forgery (CSRF) vulnerability in feishu-auth and dingtalk-auth plugins in Apache APISIX. An attacker who can get a user to click a crafted link may cause that user's browser session on a protected route to be established under the attacker's identity instead of their own. Any work the user then performs in that session, including uploads, form submissions, and account bindings, lands in the attacker's account. This issue affects Apache APISIX: from 3.17.0 through 3.18.0. Users are recommended to upgrade to version 3.19.0, which fixes the issue.",
    "evidence": "osv:BIT-apisix-2026-94220",
    "products": [
      {
        "name": {
          "value": "apisix",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "3.19.0",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "low",
    "structured": {
      "id": "BIT-apisix-2026-94220",
      "aliases": [
        "BIT-apisix-2026-94220",
        "CVE-2026-94220"
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "SEMVER",
              "events": [
                {
                  "introduced": "3.17.0"
                },
                {
                  "fixed": "3.19.0"
                }
              ]
            }
          ],
          "package": {
            "name": "apisix",
            "purl": "pkg:bitnami/apisix",
            "ecosystem": "Bitnami"
          },
          "severity": [
            {
              "type": "CVSS_V4",
              "score": "CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X"
            }
          ],
          "database_specific": {
            "source": "https://github.com/bitnami/vulndb/tree/main/data/apisix/BIT-apisix-2026-94220.json"
          }
        }
      ],
      "modified": "2026-10-09T12:00:09.180861204Z",
      "provider": "osv",
      "references": [
        "https://lists.apache.org/thread.html/bf5q45ddyr2hf3hxkt56dzjlttgpdg78",
        "https://nvd.nist.gov/vuln/detail/CVE-2026-94220"
      ],
      "provider_metadata": {
        "cpes": [
          "cpe:2.3:a:apache:apisix:*:*:*:*:*:*:*:*"
        ],
        "severity": "Low"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2026-94220",
        "evidence": "/aliases"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/database_specific/severity"
  },
  "source_id": "core-osv",
  "document_id": 120660,
  "published_at": "2026-10-09T10:43:48.749+00:00"
}