HighFix available
Payload didn't enforce field-level password update restrictions
Type: advisorySources: OSV
## Impact When an auth collection defined a field-level access.update restriction on the password field, the restriction was not enforced on the server correctly. ## Patches Users should upgrade Payload packages to `>= 3.90.0` or `>= 4.0.0-canary.34`.
- Products
- payload
- Affected versions
- Not specified
- Fixed versions
- 3.90.0, 4.0.0-canary.34
- CVEs
- CVE-2026-105855
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 27 Oct 2026, 12:14 UTC · Revision 1
Source evidence
Payload didn't enforce field-level password update restrictions
core-osv · Original sourcePublished 6 Oct 2026, 16:21 UTC
## Impact When an auth collection defined a field-level access.update restriction on the password field, the restriction was not enforced on the server correctly. ## Patches Users should upgrade Payload packages to `>= 3.90.0` or `>= 4.0.0-canary.34`.
osv:GHSA-fx49-4h83-wjv9
payload
Fixed versions: 3.90.0
payload
Fixed versions: 4.0.0-canary.34
Complete source record
{
"id": "64c5d601c885ae1cce47ae0ad0ea1270c0ebde183f8f93f2857366c1fbcca75c",
"url": "https://osv.dev/vulnerability/GHSA-fx49-4h83-wjv9",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Payload didn't enforce field-level password update restrictions",
"summary": "## Impact When an auth collection defined a field-level access.update restriction on the password field, the restriction was not enforced on the server correctly. ## Patches Users should upgrade Payload packages to `>= 3.90.0` or `>= 4.0.0-canary.34`.",
"evidence": "osv:GHSA-fx49-4h83-wjv9",
"products": [
{
"name": {
"value": "payload",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.90.0",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "payload",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "4.0.0-canary.34",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "GHSA-fx49-4h83-wjv9",
"aliases": [
"CVE-2026-105855",
"GHSA-fx49-4h83-wjv9"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N"
}
],
"affected": [
{
"ranges": [
{
"type": "SEMVER",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.90.0"
}
]
}
],
"package": {
"name": "payload",
"purl": "pkg:npm/payload",
"ecosystem": "npm"
},
"database_specific": {
"source": "https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2026/10/GHSA-fx49-4h83-wjv9/GHSA-fx49-4h83-wjv9.json"
}
},
{
"ranges": [
{
"type": "SEMVER",
"events": [
{
"introduced": "4.0.0-canary.0"
},
{
"fixed": "4.0.0-canary.34"
}
]
}
],
"package": {
"name": "payload",
"purl": "pkg:npm/payload",
"ecosystem": "npm"
},
"database_specific": {
"source": "https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2026/10/GHSA-fx49-4h83-wjv9/GHSA-fx49-4h83-wjv9.json"
}
}
],
"modified": "2026-10-06T16:30:04.321135814Z",
"provider": "osv",
"references": [
"https://github.com/payloadcms/payload/security/advisories/GHSA-fx49-4h83-wjv9",
"https://github.com/payloadcms/payload/commit/9de9e7911e29d60870a1d5480412524c63d6411e",
"https://github.com/payloadcms/payload",
"https://github.com/payloadcms/payload/releases/tag/v3.90.0"
],
"provider_metadata": {
"cwe_ids": [
"CWE-284"
],
"severity": "HIGH",
"github_reviewed": true,
"nvd_published_at": null,
"github_reviewed_at": "2026-10-06T16:21:52Z"
}
},
"related_cves": [
{
"value": "CVE-2026-105855",
"evidence": "/aliases"
}
],
"security_relevant": true,
"severity_evidence": "/database_specific/severity"
},
"source_id": "core-osv",
"document_id": 89314,
"published_at": "2026-10-06T16:21:52+00:00"
}