High
WordPress WP ERP Plugin <= 1.12.8 is vulnerable to SQL Injection
Type: advisorySources: OSV
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in weDevs WP ERP | Complete HR solution with recruitment & job listings | WooCommerce CRM & Accounting.This issue affects WP ERP | Complete HR solution with recruitment & job listings | WooCommerce CRM & Accounting: from n/a through 1.12.8.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2024-21747
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 7 Nov 2026, 16:34 UTC · Revision 1
Source evidence
WordPress WP ERP Plugin <= 1.12.8 is vulnerable to SQL Injection
core-osv · Original sourcePublished 8 Jan 2024, 16:48 UTC
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in weDevs WP ERP | Complete HR solution with recruitment & job listings | WooCommerce CRM & Accounting.This issue affects WP ERP | Complete HR solution with recruitment & job listings | WooCommerce CRM & Accounting: from n/a through 1.12.8.
osv:CVE-2024-21747
Complete source record
{
"id": "54295ed94d0b2c30b0724435945d2593ac921d5ddecb4fc172fb7456c2214699",
"url": "https://osv.dev/vulnerability/CVE-2024-21747",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "WordPress WP ERP Plugin <= 1.12.8 is vulnerable to SQL Injection",
"summary": "Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in weDevs WP ERP | Complete HR solution with recruitment & job listings | WooCommerce CRM & Accounting.This issue affects WP ERP | Complete HR solution with recruitment & job listings | WooCommerce CRM & Accounting: from n/a through 1.12.8.",
"evidence": "osv:CVE-2024-21747",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2024-21747",
"aliases": [
"CVE-2024-21747"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:N/A:L"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/wp-erp/wp-erp",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "4887693fd3cfcd77f012cfbfe3e4ab47b3e3562c"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:wedevs:wp_erp:*:*:*:*:*:wordpress:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "1.12.9"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v1.12.8",
"v1.12.7",
"v1.12.6",
"v1.12.5",
"v1.12.3",
"v1.12.2",
"v1.12.1",
"v1.12.0",
"v1.11.3",
"v1.11.2",
"v1.11.1",
"v1.11.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-21747.json"
}
}
],
"modified": "2026-10-28T02:30:51.013871020Z",
"provider": "osv",
"references": [
"https://wordpress.org/plugins",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/21xxx/CVE-2024-21747.json",
"https://nvd.nist.gov/vuln/detail/CVE-2024-21747",
"https://patchstack.com/database/vulnerability/erp/wordpress-wp-erp-plugin-1-12-8-sql-injection-vulnerability?_s_id=cve"
],
"provider_metadata": {
"cwe_ids": [
"CWE-89"
],
"cna_assigner": "Patchstack",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"fixed": "1.12.9"
}
],
"source": "AFFECTED_FIELD",
"strategy": "ChangesAt"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/21xxx/CVE-2024-21747.json"
}
},
"related_cves": [
{
"value": "CVE-2024-21747",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 519885,
"published_at": "2024-01-08T16:48:10.433+00:00"
}