Apache Pulsar: Timing attack in SASL token signature verification
Observable timing discrepancy vulnerability in Apache Pulsar SASL Authentication Provider can allow an attacker to forge a SASL Role Token that will pass signature verification. Users are recommended to upgrade to version 2.11.3, 3.0.2, or 3.1.1 which fixes the issue. Users should also consider updating the configured secret in the `saslJaasServerRoleTokenSignerSecretPath` file. Any component matching an above version running the SASL Authentication Provider is affected. That includes the Pulsar Broker, Proxy, Websocket Proxy, or Function Worker. 2.11 Pulsar users should upgrade to at least 2.11.3. 3.0 Pulsar users should upgrade to at least 3.0.2. 3.1 Pulsar users should upgrade to at least 3.1.1. Any users running Pulsar 2.8, 2.9, 2.10, and earlier should upgrade to one of the above patched versions. For additional details on this attack vector, please refer to https://codahale.com/a-lesson-in-timing-attacks/ .
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2023-51437
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 7 Nov 2026, 03:12 UTC · Revision 1
Source evidence
Apache Pulsar: Timing attack in SASL token signature verification
core-osv · Original sourcePublished 7 Feb 2024, 09:18 UTC
Observable timing discrepancy vulnerability in Apache Pulsar SASL Authentication Provider can allow an attacker to forge a SASL Role Token that will pass signature verification. Users are recommended to upgrade to version 2.11.3, 3.0.2, or 3.1.1 which fixes the issue. Users should also consider updating the configured secret in the `saslJaasServerRoleTokenSignerSecretPath` file. Any component matching an above version running the SASL Authentication Provider is affected. That includes the Pulsar Broker, Proxy, Websocket Proxy, or Function Worker. 2.11 Pulsar users should upgrade to at least 2.11.3. 3.0 Pulsar users should upgrade to at least 3.0.2. 3.1 Pulsar users should upgrade to at least 3.1.1. Any users running Pulsar 2.8, 2.9, 2.10, and earlier should upgrade to one of the above patched versions. For additional details on this attack vector, please refer to https://codahale.com/a-lesson-in-timing-attacks/ .
osv:CVE-2023-51437
Complete source record
{
"id": "b9d9ceefa738e53144084119cc98e9739e528381950aa2b411f4eab12425927b",
"url": "https://osv.dev/vulnerability/CVE-2023-51437",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Apache Pulsar: Timing attack in SASL token signature verification",
"summary": "Observable timing discrepancy vulnerability in Apache Pulsar SASL Authentication Provider can allow an attacker to forge a SASL Role Token that will pass signature verification. Users are recommended to upgrade to version 2.11.3, 3.0.2, or 3.1.1 which fixes the issue. Users should also consider updating the configured secret in the `saslJaasServerRoleTokenSignerSecretPath` file. Any component matching an above version running the SASL Authentication Provider is affected. That includes the Pulsar Broker, Proxy, Websocket Proxy, or Function Worker. 2.11 Pulsar users should upgrade to at least 2.11.3. 3.0 Pulsar users should upgrade to at least 3.0.2. 3.1 Pulsar users should upgrade to at least 3.1.1. Any users running Pulsar 2.8, 2.9, 2.10, and earlier should upgrade to one of the above patched versions. For additional details on this attack vector, please refer to https://codahale.com/a-lesson-in-timing-attacks/ .",
"evidence": "osv:CVE-2023-51437",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2023-51437",
"aliases": [
"CVE-2023-51437",
"GHSA-c57v-4vg5-cm2x"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/apache/pulsar",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"last_affected": "54359b6e85f6678695075ee9008102bfb7ee2bd6"
},
{
"introduced": "97ee1a114aa1e5df05d86a9dd47f7fe7a2194211"
},
{
"fixed": "c7ac62ca9eb718e15c3e3e4a460167643ef3f48b"
},
{
"introduced": "7636e8989f4d3fc24fce69a356d54e1c550945ed"
},
{
"fixed": "12c92fed7847965e3bc3769a91c866b2f0ec2e44"
},
{
"introduced": "8d89904bcc9e0a726435fec44e3eb03663924231"
},
{
"last_affected": "8d89904bcc9e0a726435fec44e3eb03663924231"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:apache:pulsar:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"last_affected": "2.10.5"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:apache:pulsar:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "2.11.0"
},
{
"fixed": "2.11.3"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:apache:pulsar:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "3.0.0"
},
{
"fixed": "3.0.2"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:apache:pulsar:3.1.0:-:*:*:*:*:*:*",
"range": [
{
"introduced": "3.1.0-NA"
},
{
"last_affected": "3.1.0-NA"
}
],
"source": "CPE_STRING"
},
{
"cpe": "cpe:2.3:a:apache:pulsar:3.1.0:candidate_1:*:*:*:*:*:*",
"range": [
{
"introduced": "3.1.0-candidate_1"
},
{
"last_affected": "3.1.0-candidate_1"
}
],
"source": "CPE_STRING"
}
]
}
}
],
"versions": [
"3.1.0-NA",
"v2.11.3-candidate-1",
"v3.0.2-candidate-2",
"v3.0.2-candidate-1",
"v3.1.0-candidate-1",
"v3.1.0",
"v2.10.5",
"v3.0.1-candidate-2",
"v3.0.1",
"v2.10.5-candidate-1",
"v2.11.2-candidate-1",
"v2.11.2",
"v3.0.1-candidate-1",
"v3.0.0-candidate-4",
"v3.0.0",
"v2.10.4-candidate-4",
"v2.10.4",
"v2.11.1-candidate-2",
"v2.11.1",
"v2.10.4-candidate-2",
"v2.10.4-candidate-1",
"v2.11.0-candidate-5",
"v2.11.0",
"v2.10.2-candidate-3",
"v2.10.2",
"v2.10.2-candidate-2",
"v2.10.2-candidate-1",
"v2.10.1-candidate-1",
"v2.10.1",
"v2.10.0-candidate-5",
"v2.10.0",
"v2.10.0-candidate-4",
"v2.10.0-candidate-3",
"v2.10.0-candidate-2",
"v2.10.0-candidate-1",
"v1.18",
"v1.17",
"v1.16",
"v1.15",
"v1.14"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-51437.json"
}
}
],
"modified": "2026-10-28T02:30:49.246173685Z",
"provider": "osv",
"references": [
"https://www.openwall.com/lists/oss-security/2024/02/07/1",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/51xxx/CVE-2023-51437.json",
"https://lists.apache.org/thread/5kgmvvolf5tzp5rz9xjwfg2ncwvqqgl5",
"https://nvd.nist.gov/vuln/detail/CVE-2023-51437"
],
"provider_metadata": {
"cwe_ids": [
"CWE-203"
],
"cna_assigner": "apache",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"introduced": "3.1.0"
},
{
"last_affected": "3.1.0"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandaloneSingleVersion"
}
]
},
{
"extracted_events": [
{
"range": [
{
"last_affected": "2.10.5"
},
{
"introduced": "2.11.0"
},
{
"last_affected": "2.11.2"
},
{
"introduced": "3.0.0"
},
{
"last_affected": "3.0.1"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/51xxx/CVE-2023-51437.json"
}
},
"related_cves": [
{
"value": "CVE-2023-51437",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 517655,
"published_at": "2024-02-07T09:18:19.08+00:00"
}