UnratedFix available
wget — security advisory
Absolute path traversal vulnerability in GNU Wget before 1.16, when recursion is enabled, allows remote FTP servers to write to arbitrary files, and consequently execute arbitrary code, via a LIST response that references the same filename within two entries, one of which indicates that the filename is for a symlink.
- Products
- wget
- Affected versions
- Not specified
- Fixed versions
- 1.16-1
- CVEs
- CVE-2014-4877
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 21:42 UTC · Revision 1
Source evidence
Absolute path traversal vulnerability in GNU Wget before 1.16, when recursion is enabled, allows remote FTP servers to write to arbitrary files, and consequently execute arbitrary code, via a LIST response that references the same filename within two entries, one of which indicates that the filename is for a symlink.
osv:DEBIAN-CVE-2014-4877
wget
Fixed versions: 1.16-1
wget
Fixed versions: 1.16-1
wget
Fixed versions: 1.16-1
Complete source record
{
"id": "de21593e1da34ca34222b33f37a06081da7c3fde550ad33316e84847da94fa23",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2014-4877",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2014-4877",
"summary": "Absolute path traversal vulnerability in GNU Wget before 1.16, when recursion is enabled, allows remote FTP servers to write to arbitrary files, and consequently execute arbitrary code, via a LIST response that references the same filename within two entries, one of which indicates that the filename is for a symlink.",
"evidence": "osv:DEBIAN-CVE-2014-4877",
"products": [
{
"name": {
"value": "wget",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.16-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "wget",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.16-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "wget",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.16-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "unknown",
"structured": {
"id": "DEBIAN-CVE-2014-4877",
"aliases": [
"DEBIAN-CVE-2014-4877"
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.16-1"
}
]
}
],
"package": {
"name": "wget",
"purl": "pkg:deb/debian/wget?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2014-4877.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.16-1"
}
]
}
],
"package": {
"name": "wget",
"purl": "pkg:deb/debian/wget?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2014-4877.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.16-1"
}
]
}
],
"package": {
"name": "wget",
"purl": "pkg:deb/debian/wget?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2014-4877.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-23T15:47:32.400177456Z",
"provider": "osv",
"upstream": [
"CVE-2014-4877"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2014-4877"
]
},
"related_cves": [
{
"value": "CVE-2014-4877",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": null
},
"source_id": "core-osv",
"document_id": 414174,
"published_at": "2014-10-29T10:55:05.417+00:00"
}