DataGear Graph Dataset cross site scripting
A vulnerability was found in DataGear up to 1.11.1 and classified as problematic. This issue affects some unknown processing of the component Graph Dataset Handler. The manipulation leads to cross site scripting. The attack may be initiated remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 1.12.0 is able to address this issue. It is recommended to upgrade the affected component. The identifier VDB-223565 was assigned to this vulnerability.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2023-1573
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 6 Nov 2026, 04:22 UTC · Revision 1
Source evidence
DataGear Graph Dataset cross site scripting
core-osv · Original sourcePublished 22 Mar 2023, 15:31 UTC
A vulnerability was found in DataGear up to 1.11.1 and classified as problematic. This issue affects some unknown processing of the component Graph Dataset Handler. The manipulation leads to cross site scripting. The attack may be initiated remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 1.12.0 is able to address this issue. It is recommended to upgrade the affected component. The identifier VDB-223565 was assigned to this vulnerability.
osv:CVE-2023-1573
Complete source record
{
"id": "7a5ba3f894a93a06fb0eb6bc30147cbc9a7a73eecfe705c9b26feb7cae048ec3",
"url": "https://osv.dev/vulnerability/CVE-2023-1573",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DataGear Graph Dataset cross site scripting",
"summary": "A vulnerability was found in DataGear up to 1.11.1 and classified as problematic. This issue affects some unknown processing of the component Graph Dataset Handler. The manipulation leads to cross site scripting. The attack may be initiated remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 1.12.0 is able to address this issue. It is recommended to upgrade the affected component. The identifier VDB-223565 was assigned to this vulnerability.",
"evidence": "osv:CVE-2023-1573",
"products": [],
"severity": "low",
"structured": {
"id": "CVE-2023-1573",
"aliases": [
"CVE-2023-1573"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/datageartech/datagear",
"type": "GIT",
"events": [
{
"introduced": "a49b193655129f7ee07ce157ffe46def8cbd9483"
},
{
"fixed": "0d316dd80a7c9366c3707a847dacb8b9632b1c18"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "1.11.0"
},
{
"last_affected": "1.11.0"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandaloneSingleVersion"
},
{
"range": [
{
"introduced": "1.11.1"
},
{
"last_affected": "1.11.1"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandaloneSingleVersion"
},
{
"range": [
{
"fixed": "0d316dd80a7c9366c3707a847dacb8b9632b1c18"
}
],
"source": "REFERENCES_TAG",
"original_tag": "v1.12.0"
}
]
}
}
],
"versions": [
"1.11.0",
"1.11.1",
"v1.11.1",
"v1.11.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-1573.json"
}
}
],
"modified": "2026-10-28T02:30:46.402832297Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/1xxx/CVE-2023-1573.json",
"https://nvd.nist.gov/vuln/detail/CVE-2023-1573",
"https://vuldb.com/?id.223565",
"https://vuldb.com/?ctiid.223565",
"https://github.com/datageartech/datagear/releases/tag/v1.12.0",
"https://github.com/yangyanglo/ForCVE/blob/main/2023-0x04.md"
],
"provider_metadata": {
"cwe_ids": [
"CWE-79"
],
"cna_assigner": "VulDB",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/1xxx/CVE-2023-1573.json"
}
},
"related_cves": [
{
"value": "CVE-2023-1573",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 514604,
"published_at": "2023-03-22T15:31:05.188+00:00"
}