Skip to content
Heist/ feed
Back to feed
CriticalFix available

wordpress — security advisory

Type: advisorySources: OSVAdvisory ID: DEBIAN-CVE-2007-6013

Wordpress 1.5 through 2.3.1 uses cookie values based on the MD5 hash of a password MD5 hash, which allows attackers to bypass authentication by obtaining the MD5 hash from the user database, then generating the authentication cookie from that hash.

Products
wordpress
Affected versions
Not specified
Fixed versions
2.5.0-1
CVEs
CVE-2007-6013
Confirmed fixed CVEs
Not specified
Updated in this feed
31 Oct 2026, 15:59 UTC · Revision 1

Source evidence

DEBIAN-CVE-2007-6013

core-osv · Original source

Published 19 Nov 2007, 21:46 UTC

Wordpress 1.5 through 2.3.1 uses cookie values based on the MD5 hash of a password MD5 hash, which allows attackers to bypass authentication by obtaining the MD5 hash from the user database, then generating the authentication cookie from that hash.

osv:DEBIAN-CVE-2007-6013

wordpress

Fixed versions: 2.5.0-1

wordpress

Fixed versions: 2.5.0-1

wordpress

Fixed versions: 2.5.0-1

Complete source record
{
  "id": "9a05811fa2dade1664143ae7d9fb6dbbdfbe80f044c792ef8701f86793a5b0af",
  "url": "https://osv.dev/vulnerability/DEBIAN-CVE-2007-6013",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "DEBIAN-CVE-2007-6013",
    "summary": "Wordpress 1.5 through 2.3.1 uses cookie values based on the MD5 hash of a password MD5 hash, which allows attackers to bypass authentication by obtaining the MD5 hash from the user database, then generating the authentication cookie from that hash.",
    "evidence": "osv:DEBIAN-CVE-2007-6013",
    "products": [
      {
        "name": {
          "value": "wordpress",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "2.5.0-1",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "wordpress",
          "evidence": "/affected/1/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "2.5.0-1",
            "evidence": "/affected/1/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "wordpress",
          "evidence": "/affected/2/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "2.5.0-1",
            "evidence": "/affected/2/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "critical",
    "structured": {
      "id": "DEBIAN-CVE-2007-6013",
      "aliases": [
        "DEBIAN-CVE-2007-6013"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "2.5.0-1"
                }
              ]
            }
          ],
          "package": {
            "name": "wordpress",
            "purl": "pkg:deb/debian/wordpress?arch=source&distro=bookworm",
            "ecosystem": "Debian:12"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2007-6013.json"
          },
          "ecosystem_specific": {
            "urgency": "low"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "2.5.0-1"
                }
              ]
            }
          ],
          "package": {
            "name": "wordpress",
            "purl": "pkg:deb/debian/wordpress?arch=source&distro=trixie",
            "ecosystem": "Debian:13"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2007-6013.json"
          },
          "ecosystem_specific": {
            "urgency": "low"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "2.5.0-1"
                }
              ]
            }
          ],
          "package": {
            "name": "wordpress",
            "purl": "pkg:deb/debian/wordpress?arch=source&distro=forky",
            "ecosystem": "Debian:14"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2007-6013.json"
          },
          "ecosystem_specific": {
            "urgency": "low"
          }
        }
      ],
      "modified": "2026-10-21T18:01:09.634282924Z",
      "provider": "osv",
      "upstream": [
        "CVE-2007-6013"
      ],
      "references": [
        "https://security-tracker.debian.org/tracker/CVE-2007-6013"
      ]
    },
    "related_cves": [
      {
        "value": "CVE-2007-6013",
        "evidence": "/upstream"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 398762,
  "published_at": "2007-11-19T21:46:00+00:00"
}