Skip to content
Heist/ feed
Back to feed
Critical

Security advisory

Type: advisorySources: OSVCVE: CVE-2021-25941

Prototype pollution vulnerability in 'deep-override' versions 1.0.0 through 1.0.1 allows an attacker to cause a denial of service and may lead to remote code execution.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2021-25941
Confirmed fixed CVEs
Not specified
Updated in this feed
31 Oct 2026, 11:41 UTC · Revision 1

Source evidence

CVE-2021-25941

core-osv · Original source

Published 14 May 2021, 14:15 UTC

Prototype pollution vulnerability in 'deep-override' versions 1.0.0 through 1.0.1 allows an attacker to cause a denial of service and may lead to remote code execution.

osv:CVE-2021-25941
Complete source record
{
  "id": "4ce5c1b01facd139cae41cc4e41341b547c5312911c5ef9407c07c07f585f492",
  "url": "https://osv.dev/vulnerability/CVE-2021-25941",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "CVE-2021-25941",
    "summary": "Prototype pollution vulnerability in 'deep-override' versions 1.0.0 through 1.0.1 allows an attacker to cause a denial of service and may lead to remote code execution.",
    "evidence": "osv:CVE-2021-25941",
    "products": [],
    "severity": "critical",
    "structured": {
      "id": "CVE-2021-25941",
      "aliases": [
        "CVE-2021-25941",
        "GHSA-v659-54cx-g4qr"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/asaianudeep/deep-override",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "2aced17651fb684959a6e04b1465a8329b3d5268"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "range": [
                      {
                        "fixed": "2aced17651fb684959a6e04b1465a8329b3d5268"
                      }
                    ],
                    "source": "REFERENCES_COMMIT"
                  }
                ]
              }
            }
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2021-25941.json"
          }
        }
      ],
      "modified": "2026-10-20T10:54:33.922195167Z",
      "provider": "osv",
      "references": [
        "https://github.com/ASaiAnudeep/deep-override/commit/2aced17651fb684959a6e04b1465a8329b3d5268",
        "https://www.whitesourcesoftware.com/vulnerability-database/CVE-2021-25941"
      ],
      "provider_metadata": {
        "unresolved_ranges": [
          {
            "cpes": [
              "cpe:2.3:a:deep-override_project:deep-override:*:*:*:*:*:*:*:*"
            ],
            "vendor_product": "deep-override_project:deep-override",
            "extracted_events": [
              {
                "range": [
                  {
                    "introduced": "1.0.0"
                  },
                  {
                    "fixed": "1.0.2"
                  }
                ],
                "source": "CPE_RANGE"
              }
            ]
          },
          {
            "extracted_events": [
              {
                "range": [
                  {
                    "introduced": "1.0.0"
                  },
                  {
                    "last_affected": "1.0.1"
                  }
                ],
                "source": "DESCRIPTION"
              }
            ]
          }
        ]
      }
    },
    "related_cves": [
      {
        "value": "CVE-2021-25941",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 385593,
  "published_at": "2021-05-14T14:15:07.817+00:00"
}