Command Injection
The package git-pull-or-clone before 2.0.2 are vulnerable to Command Injection due to the use of the --upload-pack feature of git which is also supported for git clone. The source includes the use of the secure child process API spawn(). However, the outpath parameter passed to it may be a command-line argument to the git clone command and result in arbitrary command injection.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2022-24437
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 2 Nov 2026, 23:29 UTC · Revision 1
Source evidence
The package git-pull-or-clone before 2.0.2 are vulnerable to Command Injection due to the use of the --upload-pack feature of git which is also supported for git clone. The source includes the use of the secure child process API spawn(). However, the outpath parameter passed to it may be a command-line argument to the git clone command and result in arbitrary command injection.
osv:CVE-2022-24437
Complete source record
{
"id": "13084abe26c397d2106332f0a8b1bcacb8b09b2ab55c8bf0083e72fa708a07a5",
"url": "https://osv.dev/vulnerability/CVE-2022-24437",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Command Injection",
"summary": "The package git-pull-or-clone before 2.0.2 are vulnerable to Command Injection due to the use of the --upload-pack feature of git which is also supported for git clone. The source includes the use of the secure child process API spawn(). However, the outpath parameter passed to it may be a command-line argument to the git clone command and result in arbitrary command injection.",
"evidence": "osv:CVE-2022-24437",
"products": [],
"severity": "critical",
"structured": {
"id": "CVE-2022-24437",
"aliases": [
"CVE-2022-24437",
"GHSA-3x62-x456-q2vm",
"SNYK-JS-GITPULLORCLONE-2434307"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/feross/git-pull-or-clone",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "7c99adeaea03aeb31631d71037fd792db0bfdc83"
},
{
"fixed": "f9ce092be13cc32e685dfa26e7705e9c6e3108a3"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:git-pull-or-clone_project:git-pull-or-clone:*:*:*:*:*:node.js:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "2.0.2"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "f9ce092be13cc32e685dfa26e7705e9c6e3108a3"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"v2.0.1",
"v2.0.0",
"v1.3.0",
"v1.2.0",
"v1.1.0",
"v1.0.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-24437.json"
}
}
],
"modified": "2026-10-28T02:30:24.563304131Z",
"provider": "osv",
"references": [
"https://gist.github.com/lirantal/327e9dd32686991b5a1fa6341aac2e7b",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/24xxx/CVE-2022-24437.json",
"https://nvd.nist.gov/vuln/detail/CVE-2022-24437",
"https://snyk.io/vuln/SNYK-JS-GITPULLORCLONE-2434307",
"https://github.com/feross/git-pull-or-clone/commit/f9ce092be13cc32e685dfa26e7705e9c6e3108a3"
],
"provider_metadata": {
"cna_assigner": "snyk",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/24xxx/CVE-2022-24437.json"
}
},
"related_cves": [
{
"value": "CVE-2022-24437",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 490879,
"published_at": "2022-05-01T15:20:15.509+00:00"
}