Skip to content
Heist/ feed
Back to feed
Medium

Discourse Calendar Event names susceptible to Cross-site Scripting

Type: advisorySources: OSV

Discourse Calendar is a calendar plugin for Discourse, an open-source messaging app. Prior to version 1.0.1, parsing and rendering of Event names can be susceptible to cross-site scripting (XSS) attacks. This vulnerability only affects sites which have modified or disabled Discourse’s default Content Security Policy. This issue is patched in version 1.0.1 of the Discourse Calendar plugin. As a workaround, ensure that the Content Security Policy is enabled, and has not been modified in a way which would make it more vulnerable to XSS attacks.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2022-31059
Confirmed fixed CVEs
Not specified
Updated in this feed
3 Nov 2026, 13:55 UTC · Revision 1

Source evidence

Discourse Calendar Event names susceptible to Cross-site Scripting

core-osv · Original source

Published 14 Jun 2022, 19:55 UTC

Discourse Calendar is a calendar plugin for Discourse, an open-source messaging app. Prior to version 1.0.1, parsing and rendering of Event names can be susceptible to cross-site scripting (XSS) attacks. This vulnerability only affects sites which have modified or disabled Discourse’s default Content Security Policy. This issue is patched in version 1.0.1 of the Discourse Calendar plugin. As a workaround, ensure that the Content Security Policy is enabled, and has not been modified in a way which would make it more vulnerable to XSS attacks.

osv:CVE-2022-31059
Complete source record
{
  "id": "7339e0f09ddfb0c5d77efb62f6f85c58724acbf9ed00bf3703ac16db1f80742a",
  "url": "https://osv.dev/vulnerability/CVE-2022-31059",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "Discourse Calendar Event names susceptible to Cross-site Scripting",
    "summary": "Discourse Calendar is a calendar plugin for Discourse, an open-source messaging app. Prior to version 1.0.1, parsing and rendering of Event names can be susceptible to cross-site scripting (XSS) attacks. This vulnerability only affects sites which have modified or disabled Discourse’s default Content Security Policy. This issue is patched in version 1.0.1 of the Discourse Calendar plugin. As a workaround, ensure that the Content Security Policy is enabled, and has not been modified in a way which would make it more vulnerable to XSS attacks.",
    "evidence": "osv:CVE-2022-31059",
    "products": [],
    "severity": "medium",
    "structured": {
      "id": "CVE-2022-31059",
      "aliases": [
        "CVE-2022-31059",
        "GHSA-c783-x9vm-xxp5"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/discourse/discourse-calendar",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "2719b9e81994e961bf8c4e12b4556dc9777dd62f"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "range": [
                      {
                        "fixed": "2719b9e81994e961bf8c4e12b4556dc9777dd62f"
                      }
                    ],
                    "source": "REFERENCES_COMMIT"
                  }
                ]
              }
            }
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-31059.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:29.371616227Z",
      "provider": "osv",
      "references": [
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/31xxx/CVE-2022-31059.json",
        "https://github.com/discourse/discourse-calendar/security/advisories/GHSA-c783-x9vm-xxp5",
        "https://nvd.nist.gov/vuln/detail/CVE-2022-31059",
        "https://github.com/discourse/discourse-calendar/commit/2719b9e81994e961bf8c4e12b4556dc9777dd62f",
        "https://github.com/discourse/discourse-calendar/pull/280"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-79"
        ],
        "cna_assigner": "GitHub_M",
        "unresolved_ranges": [
          {
            "extracted_events": [
              {
                "range": [
                  {
                    "fixed": "1.0.1"
                  }
                ],
                "source": "AFFECTED_FIELD",
                "strategy": "StringRangeExpression"
              }
            ]
          },
          {
            "extracted_events": [
              {
                "range": [
                  {
                    "fixed": "1.0.1"
                  },
                  {
                    "fixed": "1.0.1"
                  }
                ],
                "source": "DESCRIPTION"
              }
            ]
          }
        ],
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/31xxx/CVE-2022-31059.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2022-31059",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 496122,
  "published_at": "2022-06-14T19:55:10+00:00"
}