squid — security advisory
Squid is a caching proxy for the Web. Due to an Improper Validation of Specified Index bug, Squid versions 3.3.0.1 through 5.9 and 6.0 prior to 6.4 compiled using `--with-openssl` are vulnerable to a Denial of Service attack against SSL Certificate validation. This problem allows a remote server to perform Denial of Service against Squid Proxy by initiating a TLS Handshake with a specially crafted SSL Certificate in a server certificate chain. This attack is limited to HTTPS and SSL-Bump. This bug is fixed in Squid version 6.4. In addition, patches addressing this problem for the stable releases can be found in Squid's patch archives. Those who you use a prepackaged version of Squid should refer to the package vendor for availability information on updated packages.
- Products
- squid
- Affected versions
- 5.7-2
- Fixed versions
- 5.7-2+deb12u1, 6.5-1
- CVEs
- CVE-2023-46724
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 16:11 UTC · Revision 1
Source evidence
Squid is a caching proxy for the Web. Due to an Improper Validation of Specified Index bug, Squid versions 3.3.0.1 through 5.9 and 6.0 prior to 6.4 compiled using `--with-openssl` are vulnerable to a Denial of Service attack against SSL Certificate validation. This problem allows a remote server to perform Denial of Service against Squid Proxy by initiating a TLS Handshake with a specially crafted SSL Certificate in a server certificate chain. This attack is limited to HTTPS and SSL-Bump. This bug is fixed in Squid version 6.4. In addition, patches addressing this problem for the stable releases can be found in Squid's patch archives. Those who you use a prepackaged version of Squid should refer to the package vendor for availability information on updated packages.
osv:DEBIAN-CVE-2023-46724
squid
Fixed versions: 5.7-2+deb12u1
squid
Fixed versions: 6.5-1
squid
Fixed versions: 6.5-1
Complete source record
{
"id": "3bb7baa70c7ae36c0793112a89cb39601b47760cb89f142a2a09b72b2c6b0946",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2023-46724",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2023-46724",
"summary": "Squid is a caching proxy for the Web. Due to an Improper Validation of Specified Index bug, Squid versions 3.3.0.1 through 5.9 and 6.0 prior to 6.4 compiled using `--with-openssl` are vulnerable to a Denial of Service attack against SSL Certificate validation. This problem allows a remote server to perform Denial of Service against Squid Proxy by initiating a TLS Handshake with a specially crafted SSL Certificate in a server certificate chain. This attack is limited to HTTPS and SSL-Bump. This bug is fixed in Squid version 6.4. In addition, patches addressing this problem for the stable releases can be found in Squid's patch archives. Those who you use a prepackaged version of Squid should refer to the package vendor for availability information on updated packages.",
"evidence": "osv:DEBIAN-CVE-2023-46724",
"products": [
{
"name": {
"value": "squid",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "5.7-2+deb12u1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": [
{
"value": "5.7-2",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "squid",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "6.5-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "squid",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "6.5-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2023-46724",
"aliases": [
"DEBIAN-CVE-2023-46724"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "5.7-2+deb12u1"
}
]
}
],
"package": {
"name": "squid",
"purl": "pkg:deb/debian/squid?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"versions": [
"5.7-2"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2023-46724.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "6.5-1"
}
]
}
],
"package": {
"name": "squid",
"purl": "pkg:deb/debian/squid?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2023-46724.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "6.5-1"
}
]
}
],
"package": {
"name": "squid",
"purl": "pkg:deb/debian/squid?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2023-46724.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-26T18:02:49.552302939Z",
"provider": "osv",
"upstream": [
"CVE-2023-46724"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2023-46724"
]
},
"related_cves": [
{
"value": "CVE-2023-46724",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 456926,
"published_at": "2023-11-01T20:15:08.8+00:00"
}