Medium
Security advisory
WordPress before 5.2.3 allows XSS in post previews by authenticated users.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2019-16223
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 07:02 UTC · Revision 1
Source evidence
WordPress before 5.2.3 allows XSS in post previews by authenticated users.
osv:CVE-2019-16223
Complete source record
{
"id": "3d9ccb7305a2166eb740c7c784b87b9cdd1458f20f21d828d0517d9736cff1b9",
"url": "https://osv.dev/vulnerability/CVE-2019-16223",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2019-16223",
"summary": "WordPress before 5.2.3 allows XSS in post previews by authenticated users.",
"evidence": "osv:CVE-2019-16223",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2019-16223",
"aliases": [
"CVE-2019-16223"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/wordpress/wordpress",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "95929621e87a8f6e3fa22f7168ecdf4b5ae9417e"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "5.2.3"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2019-16223.json"
}
},
{
"ranges": [
{
"repo": "https://github.com/wordpress/wordpress-develop",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "ae5255196259ce2935d701ee8c91238ddf0b335e"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "5.2.3"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2019-16223.json"
}
}
],
"modified": "2026-10-24T10:30:47.660137183Z",
"provider": "osv",
"references": [
"https://lists.debian.org/debian-lts-announce/2019/10/msg00023.html",
"https://seclists.org/bugtraq/2020/Jan/8",
"https://wordpress.org/news/2019/09/wordpress-5-2-3-security-and-maintenance-release/",
"https://wpvulndb.com/vulnerabilities/9862",
"https://www.debian.org/security/2020/dsa-4599",
"https://www.debian.org/security/2020/dsa-4677"
],
"provider_metadata": {
"unresolved_ranges": [
{
"cpes": [
"cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*",
"cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*",
"cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*"
],
"vendor_product": "debian:debian_linux",
"extracted_events": [
{
"range": [
{
"introduced": "8.0"
},
{
"last_affected": "8.0"
},
{
"introduced": "9.0"
},
{
"last_affected": "9.0"
},
{
"introduced": "10.0"
},
{
"last_affected": "10.0"
}
],
"source": "CPE_STRING"
}
]
}
]
}
},
"related_cves": [
{
"value": "CVE-2019-16223",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 436593,
"published_at": "2019-09-11T14:15:12.18+00:00"
}