JumpServer has a Kubernetes Token Leak Vulnerability
JumpServer is an open source bastion host and an operation and maintenance security audit system. Prior to 4.8.0 and 3.10.18, an attacker with a low-privileged account can access the Kubernetes session feature and manipulate the kubeconfig file to redirect API requests to an external server controlled by the attacker. This allows the attacker to intercept and capture the Kubernetes cluster token. This can potentially allow unauthorized access to the cluster and compromise its security. This vulnerability is fixed in 4.8.0 and 3.10.18.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2025-27095
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 4 Nov 2026, 23:21 UTC · Revision 1
Source evidence
JumpServer has a Kubernetes Token Leak Vulnerability
core-osv · Original sourcePublished 31 Mar 2025, 15:08 UTC
JumpServer is an open source bastion host and an operation and maintenance security audit system. Prior to 4.8.0 and 3.10.18, an attacker with a low-privileged account can access the Kubernetes session feature and manipulate the kubeconfig file to redirect API requests to an external server controlled by the attacker. This allows the attacker to intercept and capture the Kubernetes cluster token. This can potentially allow unauthorized access to the cluster and compromise its security. This vulnerability is fixed in 4.8.0 and 3.10.18.
osv:CVE-2025-27095
Complete source record
{
"id": "15d519df161178becb0f01b99a164acdd6f32dac9989fe7778683b688ac36ab8",
"url": "https://osv.dev/vulnerability/CVE-2025-27095",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "JumpServer has a Kubernetes Token Leak Vulnerability",
"summary": "JumpServer is an open source bastion host and an operation and maintenance security audit system. Prior to 4.8.0 and 3.10.18, an attacker with a low-privileged account can access the Kubernetes session feature and manipulate the kubeconfig file to redirect API requests to an external server controlled by the attacker. This allows the attacker to intercept and capture the Kubernetes cluster token. This can potentially allow unauthorized access to the cluster and compromise its security. This vulnerability is fixed in 4.8.0 and 3.10.18.",
"evidence": "osv:CVE-2025-27095",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2025-27095",
"aliases": [
"CVE-2025-27095",
"GHSA-5q9w-f4wh-f535"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/jumpserver/jumpserver",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "c2e6a57f27353e07087c787dd5801b4d2b345577"
},
{
"introduced": "6e7c11d6c0d113a883500a8cbd4bff04863d98cd"
},
{
"fixed": "6d66ba528874b7758c8745b6bbe0ebed641fe1d4"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:fit2cloud:jumpserver:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "3.10.18"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:fit2cloud:jumpserver:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "4.0.0"
},
{
"fixed": "4.8.0"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v4.7.0",
"v4.6.0",
"v2.27.0",
"v2.26.0",
"v2.25.0",
"v2.24.0",
"v2.23.0",
"v2.22.0",
"v2.21.0",
"v2.20.0",
"v2.19.0",
"v2.18.1",
"v2.18.0",
"v2.17.0",
"v2.15.1",
"v2.15.0",
"v2.13.0",
"v2.12.0",
"v2.11.0",
"v2.10.0",
"v2.9.0",
"v2.8.0",
"v2.7.0",
"v2.6.0",
"v2.5.0",
"v2.4.0",
"v2.3.1",
"v2.3.0",
"v2.2.1",
"v2.2.0",
"v2.1.0",
"1.5.9",
"1.5.8",
"1.5.7",
"1.5.6",
"1.5.5",
"1.5.4",
"1.5.3",
"1.5.2",
"1.5.1",
"1.5.0",
"v1.4.10",
"1.4.10",
"1.4.9",
"1.4.8",
"1.4.7",
"v1.4.7",
"1.4.6",
"1.4.5",
"1.4.4",
"v1.4.4",
"1.4.3",
"1.4.2",
"1.4.1",
"1.4.0",
"1.3.3",
"1.3.2",
"1.3.1",
"1.3.0",
"1.2.1",
"1.2.0",
"1.1.1",
"1.1.0",
"1.0.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-27095.json"
}
}
],
"modified": "2026-10-28T02:30:40.680234801Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/27xxx/CVE-2025-27095.json",
"https://github.com/jumpserver/jumpserver/security/advisories/GHSA-5q9w-f4wh-f535",
"https://nvd.nist.gov/vuln/detail/CVE-2025-27095"
],
"provider_metadata": {
"cwe_ids": [
"CWE-266"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/27xxx/CVE-2025-27095.json"
}
},
"related_cves": [
{
"value": "CVE-2025-27095",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 507952,
"published_at": "2025-03-31T15:08:20.942+00:00"
}