High
Apache APISIX: JWT Algorithm Confusion allows authentication bypass
Type: advisorySources: OSV
Authentication Bypass by Spoofing vulnerability in Apache APISIX. The attacker can completely bypass authentication capitalising on certain configurations of jwt-auth plugin. This issue affects Apache APISIX: from v2.2 through v3.16.0. Users are recommended to upgrade to version v3.17.0, which fixes the issue.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2026-39999
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 3 Nov 2026, 12:21 UTC · Revision 1
Source evidence
Apache APISIX: JWT Algorithm Confusion allows authentication bypass
core-osv · Original sourcePublished 19 Jun 2026, 13:07 UTC
Authentication Bypass by Spoofing vulnerability in Apache APISIX. The attacker can completely bypass authentication capitalising on certain configurations of jwt-auth plugin. This issue affects Apache APISIX: from v2.2 through v3.16.0. Users are recommended to upgrade to version v3.17.0, which fixes the issue.
osv:CVE-2026-39999
Complete source record
{
"id": "f925d3f8845e38c7be66c7fd0e53bd43e5a191e717efa492d1a4476ba3f381dd",
"url": "https://osv.dev/vulnerability/CVE-2026-39999",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Apache APISIX: JWT Algorithm Confusion allows authentication bypass",
"summary": "Authentication Bypass by Spoofing vulnerability in Apache APISIX. The attacker can completely bypass authentication capitalising on certain configurations of jwt-auth plugin. This issue affects Apache APISIX: from v2.2 through v3.16.0. Users are recommended to upgrade to version v3.17.0, which fixes the issue.",
"evidence": "osv:CVE-2026-39999",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2026-39999",
"aliases": [
"BIT-apisix-2026-39999",
"CVE-2026-39999"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/apache/apisix",
"type": "GIT",
"events": [
{
"introduced": "e8dcf3793ca40b30047406ac51a79a500356f67b"
},
{
"fixed": "9ef2ecab67f652d38365049613610ef649bb4ad0"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:apache:apisix:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "2.2"
},
{
"fixed": "3.17.0"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-39999.json"
}
}
],
"modified": "2026-10-28T02:30:28.373140154Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/39xxx/CVE-2026-39999.json",
"https://lists.apache.org/thread/nfopt8cnxd3k0rs1oxtr7lzxrdw4mojq",
"https://nvd.nist.gov/vuln/detail/CVE-2026-39999"
],
"provider_metadata": {
"cwe_ids": [
"CWE-290"
],
"cna_assigner": "apache",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"introduced": "2.2"
},
{
"last_affected": "3.16.0"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/39xxx/CVE-2026-39999.json"
}
},
"related_cves": [
{
"value": "CVE-2026-39999",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 495330,
"published_at": "2026-06-19T13:07:50.893+00:00"
}