High
Security advisory
When using incomplete escape codes, Irssi before 1.0.6 may access data beyond the end of the string.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2018-5205
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 05:23 UTC · Revision 1
Source evidence
When using incomplete escape codes, Irssi before 1.0.6 may access data beyond the end of the string.
osv:CVE-2018-5205
Complete source record
{
"id": "fba7f42a28788dc8ce46b270ed5cbfefd1581a2681e6dff50cee0a7408dda440",
"url": "https://osv.dev/vulnerability/CVE-2018-5205",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2018-5205",
"summary": "When using incomplete escape codes, Irssi before 1.0.6 may access data beyond the end of the string.",
"evidence": "osv:CVE-2018-5205",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2018-5205",
"aliases": [
"CVE-2018-5205"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/irssi/irssi",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "fe6e377beb57a11ce47683055834722e0ed6ba2b"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:irssi:irssi:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "1.0.6"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"1.0.4",
"1.0.3",
"1.0.2",
"1.0.1",
"1.0.0",
"0.8.17",
"0.8.17-rc2",
"0.8.16",
"0.8.15",
"0.8.14",
"0.8.13",
"0.8.12",
"0.8.11",
"0.8.10",
"0.8.9",
"0.8.8",
"0.8.7",
"0.8.6",
"0.8.4",
"0.8.3",
"0.8.2",
"0.8.1",
"0.8.0",
"0.7.98.CVS",
"0.7.98.3",
"0.7.98.2",
"0.7.98",
"0.7.97",
"0.7.96",
"0.7.95",
"0.7.94",
"0.7.93",
"0.7.92",
"0.7.91",
"0.7.90",
"0.7.90-cvs",
"0.7.28",
"0.7.27",
"0.7.26",
"0.7.25",
"0.7.24",
"0.7.23",
"0.7.22",
"0.7.21",
"0.7.20.1",
"0.7.20",
"0.7.19",
"0.7.18",
"0.7.17",
"0.7.16"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2018-5205.json"
}
}
],
"modified": "2026-10-24T10:30:28.109574527Z",
"provider": "osv",
"references": [
"https://usn.ubuntu.com/3527-1/",
"https://www.debian.org/security/2018/dsa-4162",
"https://irssi.org/security/irssi_sa_2018_01.txt"
],
"provider_metadata": {
"unresolved_ranges": [
{
"cpes": [
"cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:lts:*:*:*",
"cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:lts:*:*:*",
"cpe:2.3:o:canonical:ubuntu_linux:17.04:*:*:*:*:*:*:*",
"cpe:2.3:o:canonical:ubuntu_linux:17.10:*:*:*:*:*:*:*"
],
"vendor_product": "canonical:ubuntu_linux",
"extracted_events": [
{
"range": [
{
"introduced": "14.04"
},
{
"last_affected": "14.04"
},
{
"introduced": "16.04"
},
{
"last_affected": "16.04"
},
{
"introduced": "17.04"
},
{
"last_affected": "17.04"
},
{
"introduced": "17.10"
},
{
"last_affected": "17.10"
}
],
"source": "CPE_STRING"
}
]
},
{
"cpes": [
"cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*"
],
"vendor_product": "debian:debian_linux",
"extracted_events": [
{
"range": [
{
"introduced": "9.0"
},
{
"last_affected": "9.0"
}
],
"source": "CPE_STRING"
}
]
}
]
}
},
"related_cves": [
{
"value": "CVE-2018-5205",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 431978,
"published_at": "2018-01-06T16:29:00.233+00:00"
}