Skip to content
Heist/ feed
Back to feed
High

Apache Guacamole: Integer overflow in handling of VNC image buffers

Type: advisorySources: OSV

Apache Guacamole 1.5.3 and older do not consistently ensure that values received from a VNC server will not result in integer overflow. If a user connects to a malicious or compromised VNC server, specially-crafted data could result in memory corruption, possibly allowing arbitrary code to be executed with the privileges of the running guacd process. Users are recommended to upgrade to version 1.5.4, which fixes this issue.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2023-43826
Confirmed fixed CVEs
Not specified
Updated in this feed
4 Nov 2026, 17:34 UTC · Revision 1

Source evidence

Apache Guacamole: Integer overflow in handling of VNC image buffers

core-osv · Original source

Published 19 Dec 2023, 19:50 UTC

Apache Guacamole 1.5.3 and older do not consistently ensure that values received from a VNC server will not result in integer overflow. If a user connects to a malicious or compromised VNC server, specially-crafted data could result in memory corruption, possibly allowing arbitrary code to be executed with the privileges of the running guacd process. Users are recommended to upgrade to version 1.5.4, which fixes this issue.

osv:CVE-2023-43826
Complete source record
{
  "id": "5a0d8d225798f19e37d67f35d29f04380613a576ac2190fadcd7c1e2c73e45d9",
  "url": "https://osv.dev/vulnerability/CVE-2023-43826",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "Apache Guacamole: Integer overflow in handling of VNC image buffers",
    "summary": "Apache Guacamole 1.5.3 and older do not consistently ensure that values received from a VNC server will not result in integer overflow. If a user connects to a malicious or compromised VNC server, specially-crafted data could result in memory corruption, possibly allowing arbitrary code to be executed with the privileges of the running guacd process. Users are recommended to upgrade to version 1.5.4, which fixes this issue.",
    "evidence": "osv:CVE-2023-43826",
    "products": [],
    "severity": "high",
    "structured": {
      "id": "CVE-2023-43826",
      "aliases": [
        "BIT-guacamole-2023-43826",
        "BIT-guacamole-server-2023-43826",
        "CVE-2023-43826"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/apache/guacamole-server",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "last_affected": "1f2ecdf69441b47610d05ad85d2fe3d18d111ba8"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:apache:guacamole:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "last_affected": "1.5.3"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "versions": [
            "1.5.3-RC2",
            "1.5.3-RC1",
            "1.5.3",
            "1.5.2-RC1",
            "1.5.2",
            "1.5.1-RC1",
            "1.5.1",
            "1.5.0-RC1",
            "1.5.0",
            "0.9.9",
            "0.9.8",
            "0.9.7",
            "0.9.6",
            "0.9.5",
            "0.9.4",
            "0.9.3",
            "0.9.2",
            "0.9.1",
            "0.8.3",
            "0.9.0",
            "0.8.2"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-43826.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:37.773752520Z",
      "provider": "osv",
      "references": [
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/43xxx/CVE-2023-43826.json",
        "https://lists.apache.org/thread/23gzwftpfgtq97tj6ttmbclry53kmwv6",
        "https://nvd.nist.gov/vuln/detail/CVE-2023-43826"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-190"
        ],
        "cna_assigner": "apache",
        "unresolved_ranges": [
          {
            "extracted_events": [
              {
                "range": [
                  {
                    "last_affected": "1.5.3"
                  }
                ],
                "source": "AFFECTED_FIELD",
                "strategy": "StandardRange"
              }
            ]
          }
        ],
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/43xxx/CVE-2023-43826.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2023-43826",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 505325,
  "published_at": "2023-12-19T19:50:15.188+00:00"
}