OpenFGA Authorization Bypass
OpenFGA is a high-performance authorization/permission engine inspired by Google Zanzibar. Versions prior to 0.2.5 are vulnerable to authorization bypass under certain conditions. You are affected by this vulnerability if you added a tuple with a wildcard (*) assigned to a tupleset relation (the right hand side of a ‘from’ statement). This issue has been patched in version v0.2.5. This update is not backward compatible with any authorization model that uses wildcard on a tupleset relation.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2022-39352
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 3 Nov 2026, 15:56 UTC · Revision 1
Source evidence
OpenFGA is a high-performance authorization/permission engine inspired by Google Zanzibar. Versions prior to 0.2.5 are vulnerable to authorization bypass under certain conditions. You are affected by this vulnerability if you added a tuple with a wildcard (*) assigned to a tupleset relation (the right hand side of a ‘from’ statement). This issue has been patched in version v0.2.5. This update is not backward compatible with any authorization model that uses wildcard on a tupleset relation.
osv:CVE-2022-39352
Complete source record
{
"id": "f41c39dc3a6c8450d41a7a54bc005c30a48f4184c7001626dc537f9ea1af14d0",
"url": "https://osv.dev/vulnerability/CVE-2022-39352",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "OpenFGA Authorization Bypass",
"summary": "OpenFGA is a high-performance authorization/permission engine inspired by Google Zanzibar. Versions prior to 0.2.5 are vulnerable to authorization bypass under certain conditions. You are affected by this vulnerability if you added a tuple with a wildcard (*) assigned to a tupleset relation (the right hand side of a ‘from’ statement). This issue has been patched in version v0.2.5. This update is not backward compatible with any authorization model that uses wildcard on a tupleset relation.",
"evidence": "osv:CVE-2022-39352",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2022-39352",
"aliases": [
"CVE-2022-39352",
"GHSA-3gfj-fxx4-f22w",
"GO-2022-1099"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/openfga/openfga",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "d33a87af80688acdad1225b23e7be6655b323d35"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "0"
},
{
"fixed": "0.2.5"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
},
{
"cpe": "cpe:2.3:a:openfga:openfga:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "0.2.5"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v0.2.4",
"v0.2.3",
"v0.2.2",
"v0.2.1",
"v0.2.0",
"v0.1.7",
"v0.1.6",
"v0.1.5",
"v0.1.4",
"v0.1.3",
"v0.1.2",
"v0.1.1",
"v0.1.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-39352.json"
}
}
],
"modified": "2026-10-28T02:30:30.187003667Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/39xxx/CVE-2022-39352.json",
"https://github.com/openfga/openfga/security/advisories/GHSA-3gfj-fxx4-f22w",
"https://nvd.nist.gov/vuln/detail/CVE-2022-39352"
],
"provider_metadata": {
"cwe_ids": [
"CWE-863"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/39xxx/CVE-2022-39352.json"
}
},
"related_cves": [
{
"value": "CVE-2022-39352",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 497066,
"published_at": "2022-11-08T00:00:00+00:00"
}