Authentication Bypass when using using older password hashes
Cacti provides an operational monitoring and fault management framework. Prior to version 1.2.27, Cacti calls `compat_password_hash` when users set their password. `compat_password_hash` use `password_hash` if there is it, else use `md5`. When verifying password, it calls `compat_password_verify`. In `compat_password_verify`, `password_verify` is called if there is it, else use `md5`. `password_verify` and `password_hash` are supported on PHP < 5.5.0, following PHP manual. The vulnerability is in `compat_password_verify`. Md5-hashed user input is compared with correct password in database by `$md5 == $hash`. It is a loose comparison, not `===`. It is a type juggling vulnerability. Version 1.2.27 contains a patch for the issue.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2024-34340
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 8 Nov 2026, 02:08 UTC · Revision 1
Source evidence
Authentication Bypass when using using older password hashes
core-osv · Original sourcePublished 13 May 2024, 15:26 UTC
Cacti provides an operational monitoring and fault management framework. Prior to version 1.2.27, Cacti calls `compat_password_hash` when users set their password. `compat_password_hash` use `password_hash` if there is it, else use `md5`. When verifying password, it calls `compat_password_verify`. In `compat_password_verify`, `password_verify` is called if there is it, else use `md5`. `password_verify` and `password_hash` are supported on PHP < 5.5.0, following PHP manual. The vulnerability is in `compat_password_verify`. Md5-hashed user input is compared with correct password in database by `$md5 == $hash`. It is a loose comparison, not `===`. It is a type juggling vulnerability. Version 1.2.27 contains a patch for the issue.
osv:CVE-2024-34340
Complete source record
{
"id": "fd9660456315db7e7e40570b6de8c7a5cbd0fd58818e1d72e2709cfb6e97225b",
"url": "https://osv.dev/vulnerability/CVE-2024-34340",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Authentication Bypass when using using older password hashes",
"summary": "Cacti provides an operational monitoring and fault management framework. Prior to version 1.2.27, Cacti calls `compat_password_hash` when users set their password. `compat_password_hash` use `password_hash` if there is it, else use `md5`. When verifying password, it calls `compat_password_verify`. In `compat_password_verify`, `password_verify` is called if there is it, else use `md5`. `password_verify` and `password_hash` are supported on PHP < 5.5.0, following PHP manual. The vulnerability is in `compat_password_verify`. Md5-hashed user input is compared with correct password in database by `$md5 == $hash`. It is a loose comparison, not `===`. It is a type juggling vulnerability. Version 1.2.27 contains a patch for the issue.",
"evidence": "osv:CVE-2024-34340",
"products": [],
"severity": "critical",
"structured": {
"id": "CVE-2024-34340",
"aliases": [
"CVE-2024-34340",
"GHSA-37x7-mfjv-mm7m"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/cacti/cacti",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "b577c294214b7e65a7273031ef8f0045d2a0c5af"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "0"
},
{
"fixed": "1.2.27"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
},
{
"cpe": "cpe:2.3:a:cacti:cacti:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "1.2.27"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"release/1.2.26",
"release/1.2.25",
"release/1.2.24",
"release/1.2.23",
"release/1.2.22",
"release/1.2.21",
"release/1.2.20",
"release/1.2.19",
"releaes/1.2.19",
"release/1.2.18",
"release/1.2.17",
"rel-1.2.17",
"release/1.2.16",
"release/1.2.15",
"release/1.2.14",
"release/1.2.13",
"release/1.2.12",
"release/1.2.11",
"release/1.2.10",
"release/1.2.9",
"release/1.2.8",
"release/1.2.7",
"release/1.2.6",
"release/1.2.5",
"release/1.2.4",
"release/1.2.3",
"release/1.2.2",
"release/1.2.1",
"release/1.2.0",
"release/1.1.38",
"release/1.1.37",
"release/1.1.36",
"release/1.1.35",
"release/1.1.34",
"release/1.1.33",
"release/1.1.32",
"release/1.1.31",
"release/1.1.30",
"release/1.1.29",
"release/1.1.28",
"release/1.1.27",
"release/1.1.26",
"release/1.1.25",
"release/1.1.24",
"release/1.1.23",
"release/1.1.22",
"release/1.1.21",
"release/1.1.20",
"release/1.1.19",
"release/1.1.18",
"release/1.1.17",
"release/1.1.16",
"release/1.1.15",
"release/1.1.14",
"release/1.1.13",
"release/1.1.12",
"release/1.1.11",
"release/1.1.8",
"release/1.1.7",
"release/1.1.6",
"release/1.1.5",
"release/1.1.4",
"release/1.1.3",
"release/1.1.2",
"release/1.1.1",
"release/1.1.0",
"release/1.0.6",
"release/1.0.5",
"release/1.0.4",
"release/1.0.3",
"release/1.0.2",
"release/1.0.1",
"release/1.0.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-34340.json"
}
}
],
"modified": "2026-10-28T02:30:53.109961810Z",
"provider": "osv",
"references": [
"https://lists.debian.org/debian-lts-announce/2024/09/msg00027.html",
"https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/RBEOAFKRARQHTDIYSL723XAFJ2Q6624X/",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/34xxx/CVE-2024-34340.json",
"https://github.com/Cacti/cacti/security/advisories/GHSA-37x7-mfjv-mm7m",
"https://nvd.nist.gov/vuln/detail/CVE-2024-34340"
],
"provider_metadata": {
"cwe_ids": [
"CWE-287",
"CWE-697"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/34xxx/CVE-2024-34340.json"
}
},
"related_cves": [
{
"value": "CVE-2024-34340",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 521644,
"published_at": "2024-05-13T15:26:32.364+00:00"
}