libgit2 — security advisory
libgit2 is a portable C implementation of the Git core methods provided as a linkable library with a solid API, allowing to build Git functionality into your application. Prior to 1.8.6 and 1.9.5, git_delta_apply in src/libgit2/delta.c trusts the attacker-controlled res_sz value parsed by hdr_sz from a delta object header and passes that amount to git__malloc before validating delta instructions. Malicious pack data supplied through git_clone, git_fetch, git_remote_fetch, git_indexer_append, or a local attacker-supplied repository can use a very small multi-level OFS_DELTA chain to retain extremely large allocations and exhaust memory. This issue is fixed in versions 1.8.6 and 1.9.5.
- Products
- libgit2
- Affected versions
- 1.5.1+ds-1, 1.5.1+ds-1+deb12u1, 1.9.0+ds-2, 1.9.1+ds-1, 1.9.2+ds-1, 1.9.2+ds-2, 1.9.2+ds-3, 1.9.2+ds-4, 1.9.2+ds-5, 1.9.2+ds-6, 1.9.2+ds-7, 1.9.2+ds-8, 1.9.2+ds-9, 1.9.3+ds-1, 1.9.4+ds-1
- Fixed versions
- 1.5.1+ds-1+deb12u2, 1.9.0+ds-2+deb13u1, 1.9.6+ds-1
- CVEs
- CVE-2026-53585
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 17:49 UTC · Revision 1
Source evidence
libgit2 is a portable C implementation of the Git core methods provided as a linkable library with a solid API, allowing to build Git functionality into your application. Prior to 1.8.6 and 1.9.5, git_delta_apply in src/libgit2/delta.c trusts the attacker-controlled res_sz value parsed by hdr_sz from a delta object header and passes that amount to git__malloc before validating delta instructions. Malicious pack data supplied through git_clone, git_fetch, git_remote_fetch, git_indexer_append, or a local attacker-supplied repository can use a very small multi-level OFS_DELTA chain to retain extremely large allocations and exhaust memory. This issue is fixed in versions 1.8.6 and 1.9.5.
osv:DEBIAN-CVE-2026-53585
libgit2
Fixed versions: 1.5.1+ds-1+deb12u2
libgit2
Fixed versions: 1.9.0+ds-2+deb13u1
libgit2
Fixed versions: 1.9.6+ds-1
Complete source record
{
"id": "7ccb9c0c44bfefe4400a04bebc0831cbbb268e05818e37cb0c099e4a6164570f",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2026-53585",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2026-53585",
"summary": "libgit2 is a portable C implementation of the Git core methods provided as a linkable library with a solid API, allowing to build Git functionality into your application. Prior to 1.8.6 and 1.9.5, git_delta_apply in src/libgit2/delta.c trusts the attacker-controlled res_sz value parsed by hdr_sz from a delta object header and passes that amount to git__malloc before validating delta instructions. Malicious pack data supplied through git_clone, git_fetch, git_remote_fetch, git_indexer_append, or a local attacker-supplied repository can use a very small multi-level OFS_DELTA chain to retain extremely large allocations and exhaust memory. This issue is fixed in versions 1.8.6 and 1.9.5.",
"evidence": "osv:DEBIAN-CVE-2026-53585",
"products": [
{
"name": {
"value": "libgit2",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.5.1+ds-1+deb12u2",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": [
{
"value": "1.5.1+ds-1",
"evidence": "/affected/0/versions"
},
{
"value": "1.5.1+ds-1+deb12u1",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "libgit2",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.9.0+ds-2+deb13u1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": [
{
"value": "1.9.0+ds-2",
"evidence": "/affected/1/versions"
}
]
},
{
"name": {
"value": "libgit2",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.9.6+ds-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": [
{
"value": "1.9.0+ds-2",
"evidence": "/affected/2/versions"
},
{
"value": "1.9.1+ds-1",
"evidence": "/affected/2/versions"
},
{
"value": "1.9.2+ds-1",
"evidence": "/affected/2/versions"
},
{
"value": "1.9.2+ds-2",
"evidence": "/affected/2/versions"
},
{
"value": "1.9.2+ds-3",
"evidence": "/affected/2/versions"
},
{
"value": "1.9.2+ds-4",
"evidence": "/affected/2/versions"
},
{
"value": "1.9.2+ds-5",
"evidence": "/affected/2/versions"
},
{
"value": "1.9.2+ds-6",
"evidence": "/affected/2/versions"
},
{
"value": "1.9.2+ds-7",
"evidence": "/affected/2/versions"
},
{
"value": "1.9.2+ds-8",
"evidence": "/affected/2/versions"
},
{
"value": "1.9.2+ds-9",
"evidence": "/affected/2/versions"
},
{
"value": "1.9.3+ds-1",
"evidence": "/affected/2/versions"
},
{
"value": "1.9.4+ds-1",
"evidence": "/affected/2/versions"
}
]
}
],
"severity": "medium",
"structured": {
"id": "DEBIAN-CVE-2026-53585",
"aliases": [
"DEBIAN-CVE-2026-53585"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.5.1+ds-1+deb12u2"
}
]
}
],
"package": {
"name": "libgit2",
"purl": "pkg:deb/debian/libgit2?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"versions": [
"1.5.1+ds-1",
"1.5.1+ds-1+deb12u1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-53585.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.9.0+ds-2+deb13u1"
}
]
}
],
"package": {
"name": "libgit2",
"purl": "pkg:deb/debian/libgit2?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"versions": [
"1.9.0+ds-2"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-53585.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.9.6+ds-1"
}
]
}
],
"package": {
"name": "libgit2",
"purl": "pkg:deb/debian/libgit2?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"versions": [
"1.9.0+ds-2",
"1.9.1+ds-1",
"1.9.2+ds-1",
"1.9.2+ds-2",
"1.9.2+ds-3",
"1.9.2+ds-4",
"1.9.2+ds-5",
"1.9.2+ds-6",
"1.9.2+ds-7",
"1.9.2+ds-8",
"1.9.2+ds-9",
"1.9.3+ds-1",
"1.9.4+ds-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-53585.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-27T09:47:38.275973458Z",
"provider": "osv",
"upstream": [
"CVE-2026-53585"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2026-53585"
]
},
"related_cves": [
{
"value": "CVE-2026-53585",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 461285,
"published_at": "2026-08-20T19:16:54.837+00:00"
}