High
Security advisory
The jQuery Validation Plugin provides drop-in validation for your existing forms. It is published as an npm package "jquery-validation". jquery-validation before version 1.19.3 contains one or more regular expressions that are vulnerable to ReDoS (Regular Expression Denial of Service). This is fixed in 1.19.3.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2021-21252
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 11:31 UTC · Revision 1
Source evidence
The jQuery Validation Plugin provides drop-in validation for your existing forms. It is published as an npm package "jquery-validation". jquery-validation before version 1.19.3 contains one or more regular expressions that are vulnerable to ReDoS (Regular Expression Denial of Service). This is fixed in 1.19.3.
osv:CVE-2021-21252
Complete source record
{
"id": "afd4a2d43a8776f94473e0b5458db7ed95c2ff1d5223239b3edf5882e837af1f",
"url": "https://osv.dev/vulnerability/CVE-2021-21252",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2021-21252",
"summary": "The jQuery Validation Plugin provides drop-in validation for your existing forms. It is published as an npm package \"jquery-validation\". jquery-validation before version 1.19.3 contains one or more regular expressions that are vulnerable to ReDoS (Regular Expression Denial of Service). This is fixed in 1.19.3.",
"evidence": "osv:CVE-2021-21252",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2021-21252",
"aliases": [
"CVE-2021-21252",
"GHSA-jxwx-85vp-gvwm"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/jquery-validation/jquery-validation",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "45b9e2857ba024514f9a46083009f25a94c17e3e"
},
{
"fixed": "5d8f29eef363d043a8fec4eb86d42cadb5fa5f7d"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:jqueryvalidation:jquery_validation:*:*:*:*:*:node.js:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "1.19.3"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "5d8f29eef363d043a8fec4eb86d42cadb5fa5f7d"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"1.11.1",
"1.11.0",
"1.10.0",
"1.9.0",
"1.8.1",
"1.8.0",
"1.8.0pre",
"1.7.0",
"1.6.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2021-21252.json"
}
}
],
"modified": "2026-10-20T10:54:27.666142894Z",
"provider": "osv",
"references": [
"https://lists.debian.org/debian-lts-announce/2023/08/msg00040.html",
"https://github.com/jquery-validation/jquery-validation/security/advisories/GHSA-jxwx-85vp-gvwm",
"https://security.netapp.com/advisory/ntap-20210219-0005/",
"https://www.npmjs.com/package/jquery-validation",
"https://github.com/jquery-validation/jquery-validation/commit/5d8f29eef363d043a8fec4eb86d42cadb5fa5f7d",
"https://github.com/jquery-validation/jquery-validation/pull/2371"
],
"provider_metadata": {}
},
"related_cves": [
{
"value": "CVE-2021-21252",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 385376,
"published_at": "2021-01-13T19:15:17.183+00:00"
}