HighFix available
PSIRT Vulnerability in OpenSSL library
Type: patchSources: Fortinet PSIRT
The OpenSSL issue can cause denial of service when crafted certificates or private keys trigger an infinite loop. Fortinet lists affected product versions and upgrade targets, and provides IPS and virtual-patch mitigations.
- Products
- FortiAnalyzer, FortiManager, FortiOS
- Affected versions
- 6.0.0 through 6.0.14, 6.2.0 through 6.2.10, 6.2.0 through 6.2.9, 6.4.0 through 6.4.7, 6.4.0 through 6.4.8, 7.0.0 through 7.0.3, 7.0.0 through 7.0.5
- Fixed versions
- 6.0.15 or above, 6.2.11 or above, 6.4.8 or above, 6.4.9 or above, 7.0.4 or above, 7.0.6 or above, 7.2.0 or above
- CVEs
- CVE-2022-0778
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 19:55 UTC · Revision 1
Source evidence
PSIRT Vulnerability in OpenSSL library
official-fortinet-psirt · Original sourcePublished 1 Apr 2022, 07:00 UTC
The OpenSSL issue can cause denial of service when crafted certificates or private keys trigger an infinite loop. Fortinet lists affected product versions and upgrade targets, and provides IPS and virtual-patch mitigations.
A security advisory was released affecting the version of OpenSSL library used in some Fortinet products: CVE-2022-0778
FortiOS
Fixed versions: 6.0.15 or above, 6.2.11 or above, 6.4.9 or above, 7.0.6 or above, 7.2.0 or above
FortiManager
Fixed versions: 6.4.8 or above, 7.0.4 or above, 7.2.0 or above
FortiAnalyzer
Fixed versions: 6.4.8 or above, 7.0.4 or above, 7.2.0 or above
Complete source record
{
"id": "098bb3252cf8bfb9b48b5525e6f5c7be0c8f18cbee02018d8123eea8124aead3",
"url": "https://fortiguard.fortinet.com/psirt/FG-IR-22-059",
"method": "llm",
"payload": {
"kind": "patch",
"title": "PSIRT Vulnerability in OpenSSL library",
"summary": "The OpenSSL issue can cause denial of service when crafted certificates or private keys trigger an infinite loop. Fortinet lists affected product versions and upgrade targets, and provides IPS and virtual-patch mitigations.",
"evidence": "A security advisory was released affecting the version of OpenSSL library used in some Fortinet products: CVE-2022-0778",
"products": [
{
"name": {
"value": "FortiOS",
"evidence": "Please upgrade to FortiOS version 6.0.15 or above."
},
"prerequisites": [],
"fixed_versions": [
{
"value": "6.0.15 or above",
"evidence": "Please upgrade to FortiOS version 6.0.15 or above."
},
{
"value": "6.2.11 or above",
"evidence": "Please upgrade to FortiOS version 6.2.11 or above."
},
{
"value": "6.4.9 or above",
"evidence": "Please upgrade to FortiOS version 6.4.9 or above."
},
{
"value": "7.0.6 or above",
"evidence": "Please upgrade to FortiOS version 7.0.6 or above."
},
{
"value": "7.2.0 or above",
"evidence": "Please upgrade to FortiOS version 7.2.0 or above."
}
],
"affected_versions": [
{
"value": "6.0.0 through 6.0.14",
"evidence": "FortiOS version 6.0.0 through 6.0.14"
},
{
"value": "6.2.0 through 6.2.10",
"evidence": "FortiOS version 6.2.0 through 6.2.10"
},
{
"value": "6.4.0 through 6.4.8",
"evidence": "FortiOS version 6.4.0 through 6.4.8"
},
{
"value": "7.0.0 through 7.0.5",
"evidence": "FortiOS version 7.0.0 through 7.0.5"
}
]
},
{
"name": {
"value": "FortiManager",
"evidence": "Please upgrade to FortiManager version 6.4.8 or above."
},
"prerequisites": [],
"fixed_versions": [
{
"value": "6.4.8 or above",
"evidence": "Please upgrade to FortiManager version 6.4.8 or above."
},
{
"value": "7.0.4 or above",
"evidence": "Please upgrade to FortiManager version 7.0.4 or above."
},
{
"value": "7.2.0 or above",
"evidence": "Please upgrade to FortiManager version 7.2.0 or above."
}
],
"affected_versions": [
{
"value": "6.2.0 through 6.2.9",
"evidence": "FortiManager version 6.2.0 through 6.2.9"
},
{
"value": "6.4.0 through 6.4.7",
"evidence": "FortiManager version 6.4.0 through 6.4.7"
},
{
"value": "7.0.0 through 7.0.3",
"evidence": "FortiManager version 7.0.0 through 7.0.3"
}
]
},
{
"name": {
"value": "FortiAnalyzer",
"evidence": "Please upgrade to FortiAnalyzer version 6.4.8 or above"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "6.4.8 or above",
"evidence": "Please upgrade to FortiAnalyzer version 6.4.8 or above"
},
{
"value": "7.0.4 or above",
"evidence": "Please upgrade to FortiAnalyzer version 7.0.4 or above"
},
{
"value": "7.2.0 or above",
"evidence": "Please upgrade to FortiAnalyzer version 7.2.0 or above"
}
],
"affected_versions": [
{
"value": "6.2.0 through 6.2.9",
"evidence": "FortiAnalyzer version 6.2.0 through 6.2.9"
},
{
"value": "6.4.0 through 6.4.7",
"evidence": "FortiAnalyzer version 6.4.0 through 6.4.7"
},
{
"value": "7.0.0 through 7.0.3",
"evidence": "FortiAnalyzer version 7.0.0 through 7.0.3"
}
]
}
],
"severity": "high",
"fixed_cves": [],
"related_cves": [
{
"value": "CVE-2022-0778",
"evidence": "CVE ID CVE-2022-0778"
}
],
"security_relevant": true,
"severity_evidence": "Severity High"
},
"source_id": "official-fortinet-psirt",
"document_id": 23572,
"published_at": "2022-04-01T07:00:00+00:00"
}