Kimai Vulnerable to Authenticated Server-Side Template Injection (SSTI)
Kimai is a web-based multi-user time-tracking application. Prior to version 2.46.0, Kimai's export functionality uses a Twig sandbox with an overly permissive security policy (`DefaultPolicy`) that allows arbitrary method calls on objects available in the template context. An authenticated user with export permissions can deploy a malicious Twig template that extracts sensitive information including environment variables, all user password hashes, serialized session tokens, and CSRF tokens. Version 2.46.0 patches this issue.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2026-23626
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 3 Nov 2026, 07:19 UTC · Revision 1
Source evidence
Kimai Vulnerable to Authenticated Server-Side Template Injection (SSTI)
core-osv · Original sourcePublished 18 Jan 2026, 22:45 UTC
Kimai is a web-based multi-user time-tracking application. Prior to version 2.46.0, Kimai's export functionality uses a Twig sandbox with an overly permissive security policy (`DefaultPolicy`) that allows arbitrary method calls on objects available in the template context. An authenticated user with export permissions can deploy a malicious Twig template that extracts sensitive information including environment variables, all user password hashes, serialized session tokens, and CSRF tokens. Version 2.46.0 patches this issue.
osv:CVE-2026-23626
Complete source record
{
"id": "f9cf6c6285bd8e2eb78c82b60f6139fbfc5a4ef9e7a7cd8301ea19e5b2571cbd",
"url": "https://osv.dev/vulnerability/CVE-2026-23626",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Kimai Vulnerable to Authenticated Server-Side Template Injection (SSTI)",
"summary": "Kimai is a web-based multi-user time-tracking application. Prior to version 2.46.0, Kimai's export functionality uses a Twig sandbox with an overly permissive security policy (`DefaultPolicy`) that allows arbitrary method calls on objects available in the template context. An authenticated user with export permissions can deploy a malicious Twig template that extracts sensitive information including environment variables, all user password hashes, serialized session tokens, and CSRF tokens. Version 2.46.0 patches this issue.",
"evidence": "osv:CVE-2026-23626",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2026-23626",
"aliases": [
"CVE-2026-23626",
"GHSA-jg2j-2w24-54cg"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:N/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/kimai/kimai",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "6a86afb5fd79f6c1825060b87c09bd1909c2e86f"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "0"
},
{
"fixed": "2.46.0"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
},
{
"range": [
{
"fixed": "6a86afb5fd79f6c1825060b87c09bd1909c2e86f"
}
],
"source": "REFERENCES_COMMIT"
},
{
"range": [
{
"fixed": "6a86afb5fd79f6c1825060b87c09bd1909c2e86f"
}
],
"source": "REFERENCES_TAG",
"original_tag": "2.46.0"
},
{
"cpe": "cpe:2.3:a:kimai:kimai:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "2.46.0"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"2.45.0",
"2.44.0",
"2.43.0",
"2.42.0",
"2.41.0",
"2.40.0",
"2.39.0",
"2.38.0",
"2.37.0",
"2.36.1",
"2.36.0",
"2.35.1",
"2.35.0",
"2.34.0",
"2.33.0",
"2.32.0",
"2.31.0",
"2.30.0",
"2.29.0",
"2.28.0",
"2.27.0",
"2.26.0",
"2.25.0",
"2.24.0",
"2.23.0",
"2.22.0",
"2.21.0",
"2.20.1",
"2.20.0",
"2.19.1",
"2.19.0",
"2.18.0",
"2.17.0",
"2.16.1",
"2.16.0",
"2.15.0",
"2.14.0",
"2.13.0",
"2.12.0",
"2.11.0",
"2.10.0",
"2.9.0",
"2.8.0",
"2.7.0",
"2.6.0",
"2.5.0",
"2.4.1",
"2.4.0",
"2.3.0",
"2.2.1",
"2.2.0",
"2.1.0",
"2.0.35",
"2.0.34",
"2.0.33",
"2.0.32",
"2.0.31",
"2.0.30",
"2.0.29",
"2.0.28",
"2.0.27",
"2.0.26",
"2.0.25",
"2.0.24",
"2.0.23",
"2.0.22",
"2.0.21",
"2.0.20",
"2.0.19",
"2.0.18",
"2.0.17",
"2.0.16",
"2.0.15",
"2.0.14",
"2.0.13",
"2.0.12",
"2.0.11",
"2.0.10",
"2.0.9",
"2.0.8",
"2.0.7",
"2.0.6",
"2.0.5",
"2.0.4",
"2.0.3",
"2.0.2",
"2.0.1",
"2.0.0",
"2.0.0-rc-1",
"2.0.0-beta-3",
"2.0.0-beta-2",
"1.30.4",
"2.0.0-beta",
"2.0.0-alpha",
"1.30.1",
"1.30.0",
"1.29.1",
"1.29.0",
"1.28.1",
"1.28.0",
"1.27.0",
"1.26.0",
"1.25.0",
"1.24.0",
"1.23.1",
"1.23.0",
"1.22.1",
"1.22.0",
"1.21.0",
"1.20.4",
"1.20.3",
"1.20.2",
"1.20.1",
"1.20",
"1.19.7",
"1.19.6",
"1.19.5",
"1.19.4",
"1.19.3",
"1.19.2",
"1.19.1",
"1.19",
"1.18.2",
"1.18.1",
"1.18",
"1.17.1",
"1.17",
"1.16.10",
"1.16.9",
"1.16.8",
"1.16.7",
"1.16.6",
"1.16.5",
"1.16.4",
"1.16.3",
"1.16.2",
"1.16.1",
"1.16",
"1.15.6",
"1.15.5",
"1.15.4",
"1.15.3",
"1.15.2",
"1.15.1",
"1.15",
"1.14.3",
"1.14.2",
"1.14.1",
"1.14",
"1.13",
"1.12",
"1.11.1",
"1.11",
"1.10.2",
"1.10.1",
"1.10",
"1.9",
"1.8",
"1.7",
"1.6.2",
"1.6.1",
"1.6",
"1.5",
"1.4.2",
"1.4.1",
"1.4",
"1.3",
"1.2",
"1.1",
"1.0.1",
"1.0",
"0.9",
"0.8.1",
"0.8",
"0.7",
"0.6.1",
"0.6",
"0.5",
"0.4",
"0.3",
"0.2",
"0.1"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-23626.json"
}
}
],
"modified": "2026-10-28T02:30:26.967764515Z",
"provider": "osv",
"references": [
"https://github.com/kimai/kimai/releases/tag/2.46.0",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/23xxx/CVE-2026-23626.json",
"https://github.com/kimai/kimai/security/advisories/GHSA-jg2j-2w24-54cg",
"https://nvd.nist.gov/vuln/detail/CVE-2026-23626",
"https://github.com/kimai/kimai/commit/6a86afb5fd79f6c1825060b87c09bd1909c2e86f",
"https://github.com/kimai/kimai/pull/5757"
],
"provider_metadata": {
"cwe_ids": [
"CWE-1336"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/23xxx/CVE-2026-23626.json"
}
},
"related_cves": [
{
"value": "CVE-2026-23626",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 493347,
"published_at": "2026-01-18T22:45:35.942+00:00"
}