Skip to content
Heist/ feed
Back to feed
HighFix available

libpod — security advisory

Type: advisorySources: OSVAdvisory ID: DEBIAN-CVE-2021-20188

A flaw was found in podman before 1.7.0. File permissions for non-root users running in a privileged container are not correctly checked. This flaw can be abused by a low-privileged user inside the container to access any other file in the container, even if owned by the root user inside the container. It does not allow to directly escape the container, though being a privileged container means that a lot of security features are disabled when running the container. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.

Products
libpod
Affected versions
Not specified
Fixed versions
2.0.2+dfsg1-3
CVEs
CVE-2021-20188
Confirmed fixed CVEs
Not specified
Updated in this feed
1 Nov 2026, 00:31 UTC · Revision 1

Source evidence

DEBIAN-CVE-2021-20188

core-osv · Original source

Published 11 Feb 2021, 18:15 UTC

A flaw was found in podman before 1.7.0. File permissions for non-root users running in a privileged container are not correctly checked. This flaw can be abused by a low-privileged user inside the container to access any other file in the container, even if owned by the root user inside the container. It does not allow to directly escape the container, though being a privileged container means that a lot of security features are disabled when running the container. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.

osv:DEBIAN-CVE-2021-20188

libpod

Fixed versions: 2.0.2+dfsg1-3

Complete source record
{
  "id": "c7761415cdb6b63aa931a3de3733c451cef1f92e63d2d13fae40b7c6b62a61a4",
  "url": "https://osv.dev/vulnerability/DEBIAN-CVE-2021-20188",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "DEBIAN-CVE-2021-20188",
    "summary": "A flaw was found in podman before 1.7.0. File permissions for non-root users running in a privileged container are not correctly checked. This flaw can be abused by a low-privileged user inside the container to access any other file in the container, even if owned by the root user inside the container. It does not allow to directly escape the container, though being a privileged container means that a lot of security features are disabled when running the container. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.",
    "evidence": "osv:DEBIAN-CVE-2021-20188",
    "products": [
      {
        "name": {
          "value": "libpod",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "2.0.2+dfsg1-3",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "high",
    "structured": {
      "id": "DEBIAN-CVE-2021-20188",
      "aliases": [
        "DEBIAN-CVE-2021-20188"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "2.0.2+dfsg1-3"
                }
              ]
            }
          ],
          "package": {
            "name": "libpod",
            "purl": "pkg:deb/debian/libpod?arch=source&distro=bookworm",
            "ecosystem": "Debian:12"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2021-20188.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        }
      ],
      "modified": "2026-10-23T18:03:24.038640969Z",
      "provider": "osv",
      "upstream": [
        "CVE-2021-20188"
      ],
      "references": [
        "https://security-tracker.debian.org/tracker/CVE-2021-20188"
      ]
    },
    "related_cves": [
      {
        "value": "CVE-2021-20188",
        "evidence": "/upstream"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 421379,
  "published_at": "2021-02-11T18:15:16.177+00:00"
}