CubeCart: Server-Side Template Injection (SSTI) in Smarty Templates leading to RCE
CubeCart is an ecommerce software solution. Prior to 6.7.0, an Authenticated Server-Side Template Injection (SSTI) vulnerability exists in multiple modules of CubeCart (including Email Templates, Invoices, Documents, and Contact Forms). The application unsafely evaluates user-supplied input using the Smarty template engine without enabling Smarty Security Policies. This allows any authenticated user with administrative privileges to execute arbitrary operating system commands (RCE) on the server. This vulnerability is fixed in 6.7.0.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2026-45714
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 2 Nov 2026, 21:08 UTC · Revision 1
Source evidence
CubeCart: Server-Side Template Injection (SSTI) in Smarty Templates leading to RCE
core-osv · Original sourcePublished 13 May 2026, 20:43 UTC
CubeCart is an ecommerce software solution. Prior to 6.7.0, an Authenticated Server-Side Template Injection (SSTI) vulnerability exists in multiple modules of CubeCart (including Email Templates, Invoices, Documents, and Contact Forms). The application unsafely evaluates user-supplied input using the Smarty template engine without enabling Smarty Security Policies. This allows any authenticated user with administrative privileges to execute arbitrary operating system commands (RCE) on the server. This vulnerability is fixed in 6.7.0.
osv:CVE-2026-45714
Complete source record
{
"id": "90bf07d881bde17f9ff864b601e9ad42cc397608f45ad2cc51f1ac63860445b0",
"url": "https://osv.dev/vulnerability/CVE-2026-45714",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CubeCart: Server-Side Template Injection (SSTI) in Smarty Templates leading to RCE",
"summary": "CubeCart is an ecommerce software solution. Prior to 6.7.0, an Authenticated Server-Side Template Injection (SSTI) vulnerability exists in multiple modules of CubeCart (including Email Templates, Invoices, Documents, and Contact Forms). The application unsafely evaluates user-supplied input using the Smarty template engine without enabling Smarty Security Policies. This allows any authenticated user with administrative privileges to execute arbitrary operating system commands (RCE) on the server. This vulnerability is fixed in 6.7.0.",
"evidence": "osv:CVE-2026-45714",
"products": [],
"severity": "critical",
"structured": {
"id": "CVE-2026-45714",
"aliases": [
"CVE-2026-45714",
"GHSA-pcfr-xgc9-xfv6"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/cubecart/v6",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "0b5a6d0f1872e634d4b0e30c08f2ec9ba19fd9b5"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "0"
},
{
"fixed": "6.7.0"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
},
{
"range": [
{
"introduced": "0"
},
{
"fixed": "6.7.0"
}
],
"source": "DESCRIPTION"
}
]
}
}
],
"versions": [
"6.6.3",
"6.6.2",
"6.6.1",
"6.6.0",
"6.5.12",
"6.5.11",
"6.5.10",
"6.5.9",
"6.5.8",
"6.5.6",
"6.5.5",
"6.5.4",
"6.5.3",
"6.5.2",
"6.5.1",
"6.5.0",
"6.4.10",
"6.4.9",
"6.4.8",
"6.4.7",
"6.4.6",
"6.4.5",
"6.4.4",
"6.4.3",
"6.4.2",
"6.4.1",
"6.4.0",
"6.4.0-b2",
"6.4.0-b1",
"6.2.9",
"6.2.8",
"2.6.7",
"6.2.6",
"6.2.5",
"6.2.4",
"6.2.3",
"6.2.2",
"6.2.1",
"6.2.0",
"6.2.0-rc2",
"6.2.0-rc1",
"6.2.0-b1",
"6.1.11pr",
"6.1.10",
"6.1.9",
"6.1.8",
"6.1.7",
"6.1.6",
"6.1.5",
"6.1.4",
"6.1.3",
"6.1.2",
"6.1.1",
"6.1.0",
"6.0.12",
"6.0.11",
"6.0.10",
"6.0.9",
"6.0.8",
"6.0.6",
"6.0.5",
"6.0.4",
"6.0.3",
"6.0.2",
"6.0.1",
"6.0.0",
"6.0.0b7",
"6.0.0b6",
"6.0.0b5",
"6.0.0b4",
"6.0.0b3",
"6.0.0b2",
"6.0.0b1"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-45714.json"
}
}
],
"modified": "2026-10-28T02:30:23.732521774Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/45xxx/CVE-2026-45714.json",
"https://github.com/cubecart/v6/security/advisories/GHSA-pcfr-xgc9-xfv6",
"https://nvd.nist.gov/vuln/detail/CVE-2026-45714"
],
"provider_metadata": {
"cwe_ids": [
"CWE-1336",
"CWE-94"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/45xxx/CVE-2026-45714.json"
}
},
"related_cves": [
{
"value": "CVE-2026-45714",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 490089,
"published_at": "2026-05-13T20:43:33.607+00:00"
}