Skip to content
Heist/ feed
Back to feed
UnratedFix available

Drupal core - Moderately critical - Cross Site Scripting - SA-CORE-2024-003

Type: patchSources: Drupal security

Drupal core has a cross-site scripting vulnerability involving status messages that are not adequately sanitized in certain situations. Update to a listed fixed version.

Products
Drupal core
Affected versions
>= 8.8.0 < 10.2.11 || >= 10.3.0 < 10.3.9 || >= 11.0.0 < 11.0.8
Fixed versions
10.2.11, 10.3.9, 11.0.8
CVEs
CVE-2024-12393
Confirmed fixed CVEs
Not specified
Updated in this feed
31 Oct 2026, 14:46 UTC · Revision 1

Source evidence

Drupal core - Moderately critical - Cross Site Scripting - SA-CORE-2024-003

official-drupal-security · Original source

Published 20 Nov 2024, 17:20 UTC

Drupal core has a cross-site scripting vulnerability involving status messages that are not adequately sanitized in certain situations. Update to a listed fixed version.

Drupal uses JavaScript to render status messages in some cases and configurations. In certain situations, the status messages are not adequately sanitized.

Drupal core

Fixed versions: 10.2.11, 10.3.9, 11.0.8

Complete source record
{
  "id": "e03e2a15c536c0bcd77cd3e54459953e15b5dc45e459e3280ce6cfaf61bdf860",
  "url": "https://www.drupal.org/sa-core-2024-003",
  "method": "llm",
  "payload": {
    "kind": "patch",
    "title": "Drupal core - Moderately critical - Cross Site Scripting - SA-CORE-2024-003",
    "summary": "Drupal core has a cross-site scripting vulnerability involving status messages that are not adequately sanitized in certain situations. Update to a listed fixed version.",
    "evidence": "Drupal uses JavaScript to render status messages in some cases and configurations. In certain situations, the status messages are not adequately sanitized.",
    "products": [
      {
        "name": {
          "value": "Drupal core",
          "evidence": "Project: Drupal core"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "10.2.11",
            "evidence": "If you are using Drupal 10.2, update to Drupal 10.2.11."
          },
          {
            "value": "10.3.9",
            "evidence": "If you are using Drupal 10.3, update to Drupal 10.3.9."
          },
          {
            "value": "11.0.8",
            "evidence": "If you are using Drupal 11.0, update to Drupal 11.0.8."
          }
        ],
        "affected_versions": [
          {
            "value": ">= 8.8.0 < 10.2.11 || >= 10.3.0 < 10.3.9 || >= 11.0.0 < 11.0.8",
            "evidence": "Affected versions: >= 8.8.0 < 10.2.11 || >= 10.3.0 < 10.3.9 || >= 11.0.0 < 11.0.8"
          }
        ]
      }
    ],
    "severity": "unknown",
    "fixed_cves": [],
    "related_cves": [
      {
        "value": "CVE-2024-12393",
        "evidence": "CVE IDs: CVE-2024-12393"
      }
    ],
    "security_relevant": true,
    "severity_evidence": null
  },
  "source_id": "official-drupal-security",
  "document_id": 23482,
  "published_at": "2024-11-20T17:20:16+00:00"
}