Skip to content
Heist/ feed
Back to feed
Medium

Security advisory

Type: advisorySources: OSVCVE: CVE-2019-20455

Gateways/Gateway.php in Heartland & Global Payments PHP SDK before 2.0.0 does not enforce SSL certificate validations.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2019-20455
Confirmed fixed CVEs
Not specified
Updated in this feed
31 Oct 2026, 10:39 UTC · Revision 1

Source evidence

CVE-2019-20455

core-osv · Original source

Published 14 Feb 2020, 16:15 UTC

Gateways/Gateway.php in Heartland & Global Payments PHP SDK before 2.0.0 does not enforce SSL certificate validations.

osv:CVE-2019-20455
Complete source record
{
  "id": "3c4be2cc7b66454ab49e7988743c00da9a70be36f431f00b7afa41552807bc1e",
  "url": "https://osv.dev/vulnerability/CVE-2019-20455",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "CVE-2019-20455",
    "summary": "Gateways/Gateway.php in Heartland & Global Payments PHP SDK before 2.0.0 does not enforce SSL certificate validations.",
    "evidence": "osv:CVE-2019-20455",
    "products": [],
    "severity": "medium",
    "structured": {
      "id": "CVE-2019-20455",
      "aliases": [
        "CVE-2019-20455",
        "GHSA-pm77-c4q7-3fwj"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/globalpayments/php-sdk",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "a73f8039b213ce6888df1f12e93fc3264d920f2e"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:globalpayments:php_sdk:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "2.0.0"
                      }
                    ],
                    "source": "CPE_RANGE"
                  },
                  {
                    "range": [
                      {
                        "fixed": "a73f8039b213ce6888df1f12e93fc3264d920f2e"
                      }
                    ],
                    "source": "REFERENCES_TAG",
                    "original_tag": "2.0.0"
                  }
                ]
              }
            }
          ],
          "versions": [
            "1.3.3",
            "1.3.2",
            "1.3.1",
            "1.3.0",
            "1.2.3",
            "1.2.2",
            "1.2.1",
            "1.2.0",
            "1.1.2",
            "1.1.1",
            "1.1.0",
            "1.0.0"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2019-20455.json"
          }
        }
      ],
      "modified": "2026-10-20T10:50:54.659016588Z",
      "provider": "osv",
      "references": [
        "https://github.com/globalpayments/php-sdk/releases/tag/2.0.0",
        "https://github.com/globalpayments/php-sdk/compare/1.3.3...2.0.0",
        "https://winterdragon.ca/global-payments-vulnerability/",
        "https://github.com/globalpayments/php-sdk/pull/8"
      ],
      "provider_metadata": {}
    },
    "related_cves": [
      {
        "value": "CVE-2019-20455",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 382336,
  "published_at": "2020-02-14T16:15:09.68+00:00"
}