Security advisory
hyper is an HTTP library for rust. hyper's HTTP/1 server code had a flaw that incorrectly parses and accepts requests with a `Content-Length` header with a prefixed plus sign, when it should have been rejected as illegal. This combined with an upstream HTTP proxy that doesn't parse such `Content-Length` headers, but forwards them, can result in "request smuggling" or "desync attacks". The flaw exists in all prior versions of hyper prior to 0.14.10, if built with `rustc` v1.5.0 or newer. The vulnerability is patched in hyper version 0.14.10. Two workarounds exist: One may reject requests manually that contain a plus sign prefix in the `Content-Length` header or ensure any upstream proxy handles `Content-Length` headers with a plus sign prefix.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2021-32715
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 11:16 UTC · Revision 1
Source evidence
hyper is an HTTP library for rust. hyper's HTTP/1 server code had a flaw that incorrectly parses and accepts requests with a `Content-Length` header with a prefixed plus sign, when it should have been rejected as illegal. This combined with an upstream HTTP proxy that doesn't parse such `Content-Length` headers, but forwards them, can result in "request smuggling" or "desync attacks". The flaw exists in all prior versions of hyper prior to 0.14.10, if built with `rustc` v1.5.0 or newer. The vulnerability is patched in hyper version 0.14.10. Two workarounds exist: One may reject requests manually that contain a plus sign prefix in the `Content-Length` header or ensure any upstream proxy handles `Content-Length` headers with a plus sign prefix.
osv:CVE-2021-32715
Complete source record
{
"id": "00d457489477f938c23f32e74ab8804d2ea53b61d99dc92b154c0fcd050d3c8e",
"url": "https://osv.dev/vulnerability/CVE-2021-32715",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2021-32715",
"summary": "hyper is an HTTP library for rust. hyper's HTTP/1 server code had a flaw that incorrectly parses and accepts requests with a `Content-Length` header with a prefixed plus sign, when it should have been rejected as illegal. This combined with an upstream HTTP proxy that doesn't parse such `Content-Length` headers, but forwards them, can result in \"request smuggling\" or \"desync attacks\". The flaw exists in all prior versions of hyper prior to 0.14.10, if built with `rustc` v1.5.0 or newer. The vulnerability is patched in hyper version 0.14.10. Two workarounds exist: One may reject requests manually that contain a plus sign prefix in the `Content-Length` header or ensure any upstream proxy handles `Content-Length` headers with a plus sign prefix.",
"evidence": "osv:CVE-2021-32715",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2021-32715",
"aliases": [
"CVE-2021-32715",
"GHSA-f3pg-qwvg-p99c",
"RUSTSEC-2021-0078"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/hyperium/hyper",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "9b69cbc2543e437f17c4a028b734f55928358675"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:hyper:hyper:*:*:*:*:*:rust:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "0.14.10"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v0.14.9",
"v0.14.8",
"v0.14.7",
"v0.14.6",
"v0.14.5",
"v0.14.4",
"v0.14.3",
"v0.13.9",
"v0.14.2",
"v0.14.1",
"v0.14.0",
"v0.13.8",
"v0.13.7",
"v0.13.6",
"v0.13.5",
"v0.13.4",
"v0.13.3",
"v0.13.2",
"v0.13.1",
"v0.13.0",
"v0.13.0-alpha.4",
"v0.13.0-alpha.3",
"v0.13.0-alpha.2",
"v0.13.0-alpha.1",
"v0.12.32",
"v0.12.31",
"v0.12.30",
"v0.12.29",
"v0.12.28",
"v0.12.27",
"v0.12.26",
"v0.12.25",
"v0.12.24",
"v0.12.23",
"v0.12.22",
"v0.12.21",
"v0.12.20",
"v0.12.19",
"v0.12.18",
"v0.12.17",
"v0.12.16",
"v0.12.15",
"v0.12.14",
"v0.12.13",
"v0.12.12",
"v0.12.11",
"v0.12.10",
"v0.12.9",
"v0.12.8",
"v0.12.7",
"v0.12.6",
"v0.12.5",
"v0.12.4",
"v0.12.3",
"v0.12.2",
"v0.12.1",
"v0.12.0",
"v0.11.22",
"v0.11.21",
"v0.11.20",
"v0.11.19",
"v0.11.18",
"v0.11.17",
"v0.11.16",
"v0.11.15",
"v0.11.14",
"v0.11.13",
"v0.11.12",
"v0.11.11",
"v0.11.10",
"v0.11.9",
"v0.11.8",
"v0.11.7",
"v0.11.6",
"v0.11.5",
"v0.11.4",
"v0.11.3",
"v0.11.2",
"v0.11.1",
"v0.11.0",
"v0.9.4",
"v0.9.3",
"v0.9.2",
"v0.9.1",
"v0.9.0",
"v0.8.1",
"v0.8.0",
"v0.7.2",
"v0.7.1",
"v0.7.0",
"v0.6.16",
"v0.6.14",
"v0.6.12",
"v0.6.11",
"v0.6.10",
"v0.6.9",
"v0.6.8",
"v0.6.5",
"v0.6.4",
"v0.6.3",
"v0.6.2",
"v0.6.1",
"v0.6.0",
"v0.5.2",
"v0.5.1",
"v0.5.0",
"v0.4.0",
"v0.3.16",
"v0.3.15",
"v0.3.14",
"v0.3.13",
"v0.3.12",
"v0.3.11",
"v0.3.10",
"v0.3.9",
"v0.3.8",
"v0.3.7",
"v0.3.6",
"v0.3.5",
"v0.3.4",
"v0.3.3",
"v0.3.1",
"v0.3.0",
"v0.2.1",
"v0.2.0",
"v0.1.13",
"v0.1.12",
"v0.1.11",
"v0.1.10",
"v0.1.9",
"v0.1.8",
"v0.1.7",
"v0.1.6",
"v0.1.5",
"v0.1.4",
"v0.1.3",
"v0.1.2",
"v0.1.1",
"v0.1.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2021-32715.json"
}
}
],
"modified": "2026-10-20T10:53:45.296790126Z",
"provider": "osv",
"references": [
"https://github.com/rust-lang/rust/pull/28826/commits/123a83326fb95366e94a3be1a74775df4db97739",
"https://github.com/hyperium/hyper/security/advisories/GHSA-f3pg-qwvg-p99c"
],
"provider_metadata": {}
},
"related_cves": [
{
"value": "CVE-2021-32715",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 384579,
"published_at": "2021-07-07T20:15:08.75+00:00"
}