Skip to content
Heist/ feed
Back to feed
HighFix available

nsis — security advisory

Type: advisorySources: OSVAdvisory ID: DEBIAN-CVE-2025-43715

Nullsoft Scriptable Install System (NSIS) before 3.11 on Windows allows local users to escalate privileges to SYSTEM during an installation, because the temporary plugins directory is created under %WINDIR%\temp and unprivileged users can place a crafted executable file by winning a race condition. This occurs because EW_CREATEDIR does not always set the CreateRestrictedDirectory error flag.

Products
nsis
Affected versions
3.08-3, 3.08-3+deb12u1, 3.09-1, 3.09-2, 3.09-3, 3.09-4, 3.10-1, 3.10-2, 3.11-1, 3.12-1
Fixed versions
3.11-1
CVEs
CVE-2025-43715
Confirmed fixed CVEs
Not specified
Updated in this feed
30 Oct 2026, 16:42 UTC · Revision 1

Source evidence

DEBIAN-CVE-2025-43715

core-osv · Original source

Published 17 Apr 2025, 03:15 UTC

Nullsoft Scriptable Install System (NSIS) before 3.11 on Windows allows local users to escalate privileges to SYSTEM during an installation, because the temporary plugins directory is created under %WINDIR%\temp and unprivileged users can place a crafted executable file by winning a race condition. This occurs because EW_CREATEDIR does not always set the CreateRestrictedDirectory error flag.

osv:DEBIAN-CVE-2025-43715

nsis

Fixed versions: Not specified

nsis

Fixed versions: 3.11-1

nsis

Fixed versions: 3.11-1

Complete source record
{
  "id": "422ee6329f90f3263222f3e23b60220d9f6147d92099b3a472f3d676d094a7c0",
  "url": "https://osv.dev/vulnerability/DEBIAN-CVE-2025-43715",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "DEBIAN-CVE-2025-43715",
    "summary": "Nullsoft Scriptable Install System (NSIS) before 3.11 on Windows allows local users to escalate privileges to SYSTEM during an installation, because the temporary plugins directory is created under %WINDIR%\\temp and unprivileged users can place a crafted executable file by winning a race condition. This occurs because EW_CREATEDIR does not always set the CreateRestrictedDirectory error flag.",
    "evidence": "osv:DEBIAN-CVE-2025-43715",
    "products": [
      {
        "name": {
          "value": "nsis",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [],
        "affected_versions": [
          {
            "value": "3.08-3",
            "evidence": "/affected/0/versions"
          },
          {
            "value": "3.08-3+deb12u1",
            "evidence": "/affected/0/versions"
          },
          {
            "value": "3.09-1",
            "evidence": "/affected/0/versions"
          },
          {
            "value": "3.09-2",
            "evidence": "/affected/0/versions"
          },
          {
            "value": "3.09-3",
            "evidence": "/affected/0/versions"
          },
          {
            "value": "3.09-4",
            "evidence": "/affected/0/versions"
          },
          {
            "value": "3.10-1",
            "evidence": "/affected/0/versions"
          },
          {
            "value": "3.10-2",
            "evidence": "/affected/0/versions"
          },
          {
            "value": "3.11-1",
            "evidence": "/affected/0/versions"
          },
          {
            "value": "3.12-1",
            "evidence": "/affected/0/versions"
          }
        ]
      },
      {
        "name": {
          "value": "nsis",
          "evidence": "/affected/1/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "3.11-1",
            "evidence": "/affected/1/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "nsis",
          "evidence": "/affected/2/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "3.11-1",
            "evidence": "/affected/2/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "high",
    "structured": {
      "id": "DEBIAN-CVE-2025-43715",
      "aliases": [
        "DEBIAN-CVE-2025-43715"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                }
              ]
            }
          ],
          "package": {
            "name": "nsis",
            "purl": "pkg:deb/debian/nsis?arch=source&distro=bookworm",
            "ecosystem": "Debian:12"
          },
          "versions": [
            "3.08-3",
            "3.08-3+deb12u1",
            "3.09-1",
            "3.09-2",
            "3.09-3",
            "3.09-4",
            "3.10-1",
            "3.10-2",
            "3.11-1",
            "3.12-1"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2025-43715.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "3.11-1"
                }
              ]
            }
          ],
          "package": {
            "name": "nsis",
            "purl": "pkg:deb/debian/nsis?arch=source&distro=trixie",
            "ecosystem": "Debian:13"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2025-43715.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "3.11-1"
                }
              ]
            }
          ],
          "package": {
            "name": "nsis",
            "purl": "pkg:deb/debian/nsis?arch=source&distro=forky",
            "ecosystem": "Debian:14"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2025-43715.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        }
      ],
      "modified": "2026-10-15T09:47:36.965370322Z",
      "provider": "osv",
      "upstream": [
        "CVE-2025-43715"
      ],
      "references": [
        "https://security-tracker.debian.org/tracker/CVE-2025-43715"
      ]
    },
    "related_cves": [
      {
        "value": "CVE-2025-43715",
        "evidence": "/upstream"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 327975,
  "published_at": "2025-04-17T03:15:16.457+00:00"
}