cups — security advisory
OpenPrinting CUPS is an open source printing system for Linux and other Unix-like operating systems. Prior to version 2.4.15, a user in the lpadmin group can use the cups web ui to change the config and insert a malicious line. Then the cupsd process which runs as root will parse the new config and cause an out-of-bound write. This issue has been patched in version 2.4.15.
- Products
- cups
- Affected versions
- 2.4.10-1, 2.4.10-2, 2.4.10-3, 2.4.10-3+deb13u1, 2.4.10-3+deb13u2, 2.4.10-4, 2.4.14-1, 2.4.15-1, 2.4.16-1, 2.4.17-1, 2.4.18-1, 2.4.2-3, 2.4.2-3+deb12u1, 2.4.2-3+deb12u2, 2.4.2-3+deb12u3, 2.4.2-3+deb12u4, 2.4.2-3+deb12u5, 2.4.2-3+deb12u6, 2.4.2-3+deb12u7, 2.4.2-3+deb12u8, 2.4.2-3+deb12u9, 2.4.2-4, 2.4.2-5, 2.4.2-6, 2.4.7-1, 2.4.7-1.1, 2.4.7-1.2, 2.4.7-2, 2.4.7-3
- Fixed versions
- 2.4.15-1
- CVEs
- CVE-2025-61915
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 28 Oct 2026, 09:03 UTC · Revision 1
Source evidence
OpenPrinting CUPS is an open source printing system for Linux and other Unix-like operating systems. Prior to version 2.4.15, a user in the lpadmin group can use the cups web ui to change the config and insert a malicious line. Then the cupsd process which runs as root will parse the new config and cause an out-of-bound write. This issue has been patched in version 2.4.15.
osv:DEBIAN-CVE-2025-61915
cups
Fixed versions: Not specified
cups
Fixed versions: Not specified
cups
Fixed versions: 2.4.15-1
Complete source record
{
"id": "d8a895af3dadb02c9057222d0db5e36fe238fe69fdce020bb2c6d86e27c80d2d",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2025-61915",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2025-61915",
"summary": "OpenPrinting CUPS is an open source printing system for Linux and other Unix-like operating systems. Prior to version 2.4.15, a user in the lpadmin group can use the cups web ui to change the config and insert a malicious line. Then the cupsd process which runs as root will parse the new config and cause an out-of-bound write. This issue has been patched in version 2.4.15.",
"evidence": "osv:DEBIAN-CVE-2025-61915",
"products": [
{
"name": {
"value": "cups",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "2.4.10-1",
"evidence": "/affected/0/versions"
},
{
"value": "2.4.10-2",
"evidence": "/affected/0/versions"
},
{
"value": "2.4.10-3",
"evidence": "/affected/0/versions"
},
{
"value": "2.4.10-4",
"evidence": "/affected/0/versions"
},
{
"value": "2.4.14-1",
"evidence": "/affected/0/versions"
},
{
"value": "2.4.15-1",
"evidence": "/affected/0/versions"
},
{
"value": "2.4.16-1",
"evidence": "/affected/0/versions"
},
{
"value": "2.4.17-1",
"evidence": "/affected/0/versions"
},
{
"value": "2.4.18-1",
"evidence": "/affected/0/versions"
},
{
"value": "2.4.2-3",
"evidence": "/affected/0/versions"
},
{
"value": "2.4.2-3+deb12u1",
"evidence": "/affected/0/versions"
},
{
"value": "2.4.2-3+deb12u2",
"evidence": "/affected/0/versions"
},
{
"value": "2.4.2-3+deb12u3",
"evidence": "/affected/0/versions"
},
{
"value": "2.4.2-3+deb12u4",
"evidence": "/affected/0/versions"
},
{
"value": "2.4.2-3+deb12u5",
"evidence": "/affected/0/versions"
},
{
"value": "2.4.2-3+deb12u6",
"evidence": "/affected/0/versions"
},
{
"value": "2.4.2-3+deb12u7",
"evidence": "/affected/0/versions"
},
{
"value": "2.4.2-3+deb12u8",
"evidence": "/affected/0/versions"
},
{
"value": "2.4.2-3+deb12u9",
"evidence": "/affected/0/versions"
},
{
"value": "2.4.2-4",
"evidence": "/affected/0/versions"
},
{
"value": "2.4.2-5",
"evidence": "/affected/0/versions"
},
{
"value": "2.4.2-6",
"evidence": "/affected/0/versions"
},
{
"value": "2.4.7-1",
"evidence": "/affected/0/versions"
},
{
"value": "2.4.7-1.1",
"evidence": "/affected/0/versions"
},
{
"value": "2.4.7-1.2",
"evidence": "/affected/0/versions"
},
{
"value": "2.4.7-2",
"evidence": "/affected/0/versions"
},
{
"value": "2.4.7-3",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "cups",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "2.4.10-3",
"evidence": "/affected/1/versions"
},
{
"value": "2.4.10-3+deb13u1",
"evidence": "/affected/1/versions"
},
{
"value": "2.4.10-3+deb13u2",
"evidence": "/affected/1/versions"
},
{
"value": "2.4.10-4",
"evidence": "/affected/1/versions"
},
{
"value": "2.4.14-1",
"evidence": "/affected/1/versions"
},
{
"value": "2.4.15-1",
"evidence": "/affected/1/versions"
},
{
"value": "2.4.16-1",
"evidence": "/affected/1/versions"
},
{
"value": "2.4.17-1",
"evidence": "/affected/1/versions"
},
{
"value": "2.4.18-1",
"evidence": "/affected/1/versions"
}
]
},
{
"name": {
"value": "cups",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.4.15-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": [
{
"value": "2.4.10-3",
"evidence": "/affected/2/versions"
},
{
"value": "2.4.10-4",
"evidence": "/affected/2/versions"
},
{
"value": "2.4.14-1",
"evidence": "/affected/2/versions"
}
]
}
],
"severity": "medium",
"structured": {
"id": "DEBIAN-CVE-2025-61915",
"aliases": [
"DEBIAN-CVE-2025-61915"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "cups",
"purl": "pkg:deb/debian/cups?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"versions": [
"2.4.10-1",
"2.4.10-2",
"2.4.10-3",
"2.4.10-4",
"2.4.14-1",
"2.4.15-1",
"2.4.16-1",
"2.4.17-1",
"2.4.18-1",
"2.4.2-3",
"2.4.2-3+deb12u1",
"2.4.2-3+deb12u2",
"2.4.2-3+deb12u3",
"2.4.2-3+deb12u4",
"2.4.2-3+deb12u5",
"2.4.2-3+deb12u6",
"2.4.2-3+deb12u7",
"2.4.2-3+deb12u8",
"2.4.2-3+deb12u9",
"2.4.2-4",
"2.4.2-5",
"2.4.2-6",
"2.4.7-1",
"2.4.7-1.1",
"2.4.7-1.2",
"2.4.7-2",
"2.4.7-3"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2025-61915.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "cups",
"purl": "pkg:deb/debian/cups?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"versions": [
"2.4.10-3",
"2.4.10-3+deb13u1",
"2.4.10-3+deb13u2",
"2.4.10-4",
"2.4.14-1",
"2.4.15-1",
"2.4.16-1",
"2.4.17-1",
"2.4.18-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2025-61915.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.4.15-1"
}
]
}
],
"package": {
"name": "cups",
"purl": "pkg:deb/debian/cups?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"versions": [
"2.4.10-3",
"2.4.10-4",
"2.4.14-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2025-61915.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-08T09:47:38.551159508Z",
"provider": "osv",
"upstream": [
"CVE-2025-61915"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2025-61915"
]
},
"related_cves": [
{
"value": "CVE-2025-61915",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 98916,
"published_at": "2025-11-29T03:15:59.52+00:00"
}