UnratedFix available
Drupal core - Moderately critical - Third-party libraries - SA-CORE-2022-011
Type: advisorySources: Drupal security
Drupal core’s advisory concerns third-party Guzzle vulnerabilities that do not affect Drupal core but may affect contributed or custom projects using Guzzle for outgoing requests. The announcement recommends updating Drupal 9.2 or 9.3 to the listed fixed versions; Drupal 7 is not affected.
- Products
- Drupal core
- Affected versions
- >= 8.0.0 <9.2.21 || >= 9.3.0 <9.3.16
- Fixed versions
- 9.2.21, 9.3.16, 9.4.0-rc2
- CVEs
- CVE-2022-31042, CVE-2022-31043
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 14:40 UTC · Revision 1
Source evidence
Drupal core - Moderately critical - Third-party libraries - SA-CORE-2022-011
official-drupal-security · Original sourcePublished 10 Jun 2022, 19:39 UTC
Drupal core’s advisory concerns third-party Guzzle vulnerabilities that do not affect Drupal core but may affect contributed or custom projects using Guzzle for outgoing requests. The announcement recommends updating Drupal 9.2 or 9.3 to the listed fixed versions; Drupal 7 is not affected.
These do not affect Drupal core, but may affect some contributed projects or custom code on Drupal sites.
Drupal core
Fixed versions: 9.3.16, 9.2.21, 9.4.0-rc2
Complete source record
{
"id": "6fab178092702f1cce8b75b0dd0151e5221e874d92772e812034ae2d81ce87dd",
"url": "https://www.drupal.org/sa-core-2022-011",
"method": "llm",
"payload": {
"kind": "advisory",
"title": "Drupal core - Moderately critical - Third-party libraries - SA-CORE-2022-011",
"summary": "Drupal core’s advisory concerns third-party Guzzle vulnerabilities that do not affect Drupal core but may affect contributed or custom projects using Guzzle for outgoing requests. The announcement recommends updating Drupal 9.2 or 9.3 to the listed fixed versions; Drupal 7 is not affected.",
"evidence": "These do not affect Drupal core, but may affect some contributed projects or custom code on Drupal sites.",
"products": [
{
"name": {
"value": "Drupal core",
"evidence": "Project: Drupal core"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "9.3.16",
"evidence": "If you are using Drupal 9.3, update to Drupal 9.3.16."
},
{
"value": "9.2.21",
"evidence": "If you are using Drupal 9.2, update to Drupal 9.2.21."
},
{
"value": "9.4.0-rc2",
"evidence": "If you are using Drupal 9.4, update to Drupal 9.4.0-rc2."
}
],
"affected_versions": [
{
"value": ">= 8.0.0 <9.2.21 || >= 9.3.0 <9.3.16",
"evidence": "Affected versions: >= 8.0.0 <9.2.21 || >= 9.3.0 <9.3.16"
}
]
}
],
"severity": "unknown",
"fixed_cves": [],
"related_cves": [
{
"value": "CVE-2022-31042",
"evidence": "CVE IDs: CVE-2022-31042 CVE-2022-31043"
},
{
"value": "CVE-2022-31043",
"evidence": "CVE IDs: CVE-2022-31042 CVE-2022-31043"
}
],
"security_relevant": true,
"severity_evidence": null
},
"source_id": "official-drupal-security",
"document_id": 23496,
"published_at": "2022-06-10T19:39:02+00:00"
}