Skip to content
Heist/ feed
Back to feed
HighFix available

libowasp-antisamy-java — security advisory

Type: advisorySources: OSVAdvisory ID: DEBIAN-CVE-2022-28366

Certain Neko-related HTML parsers allow a denial of service via crafted Processing Instruction (PI) input that causes excessive heap memory consumption. In particular, this issue exists in HtmlUnit-Neko through 2.26, and is fixed in 2.27. This issue also exists in CyberNeko HTML through 1.9.22 (also affecting OWASP AntiSamy before 1.6.6), but 1.9.22 is the last version of CyberNeko HTML. NOTE: this may be related to CVE-2022-24839.

Products
libowasp-antisamy-java
Affected versions
1.5.3+dfsg-1.1, 1.7.4-1
Fixed versions
1.7.4-1
CVEs
CVE-2022-28366
Confirmed fixed CVEs
Not specified
Updated in this feed
30 Oct 2026, 14:55 UTC · Revision 1

Source evidence

DEBIAN-CVE-2022-28366

core-osv · Original source

Published 21 Apr 2022, 23:15 UTC

Certain Neko-related HTML parsers allow a denial of service via crafted Processing Instruction (PI) input that causes excessive heap memory consumption. In particular, this issue exists in HtmlUnit-Neko through 2.26, and is fixed in 2.27. This issue also exists in CyberNeko HTML through 1.9.22 (also affecting OWASP AntiSamy before 1.6.6), but 1.9.22 is the last version of CyberNeko HTML. NOTE: this may be related to CVE-2022-24839.

osv:DEBIAN-CVE-2022-28366

libowasp-antisamy-java

Fixed versions: Not specified

libowasp-antisamy-java

Fixed versions: 1.7.4-1

libowasp-antisamy-java

Fixed versions: 1.7.4-1

Complete source record
{
  "id": "b3647ebd31a89d62b9cc6762a5ba9a943f2b91b0d6f79c0cd6f2d1ef90752a90",
  "url": "https://osv.dev/vulnerability/DEBIAN-CVE-2022-28366",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "DEBIAN-CVE-2022-28366",
    "summary": "Certain Neko-related HTML parsers allow a denial of service via crafted Processing Instruction (PI) input that causes excessive heap memory consumption. In particular, this issue exists in HtmlUnit-Neko through 2.26, and is fixed in 2.27. This issue also exists in CyberNeko HTML through 1.9.22 (also affecting OWASP AntiSamy before 1.6.6), but 1.9.22 is the last version of CyberNeko HTML. NOTE: this may be related to CVE-2022-24839.",
    "evidence": "osv:DEBIAN-CVE-2022-28366",
    "products": [
      {
        "name": {
          "value": "libowasp-antisamy-java",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [],
        "affected_versions": [
          {
            "value": "1.5.3+dfsg-1.1",
            "evidence": "/affected/0/versions"
          },
          {
            "value": "1.7.4-1",
            "evidence": "/affected/0/versions"
          }
        ]
      },
      {
        "name": {
          "value": "libowasp-antisamy-java",
          "evidence": "/affected/1/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "1.7.4-1",
            "evidence": "/affected/1/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "libowasp-antisamy-java",
          "evidence": "/affected/2/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "1.7.4-1",
            "evidence": "/affected/2/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "high",
    "structured": {
      "id": "DEBIAN-CVE-2022-28366",
      "aliases": [
        "DEBIAN-CVE-2022-28366"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                }
              ]
            }
          ],
          "package": {
            "name": "libowasp-antisamy-java",
            "purl": "pkg:deb/debian/libowasp-antisamy-java?arch=source&distro=bookworm",
            "ecosystem": "Debian:12"
          },
          "versions": [
            "1.5.3+dfsg-1.1",
            "1.7.4-1"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-28366.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "1.7.4-1"
                }
              ]
            }
          ],
          "package": {
            "name": "libowasp-antisamy-java",
            "purl": "pkg:deb/debian/libowasp-antisamy-java?arch=source&distro=trixie",
            "ecosystem": "Debian:13"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-28366.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "1.7.4-1"
                }
              ]
            }
          ],
          "package": {
            "name": "libowasp-antisamy-java",
            "purl": "pkg:deb/debian/libowasp-antisamy-java?arch=source&distro=forky",
            "ecosystem": "Debian:14"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-28366.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        }
      ],
      "modified": "2026-10-15T08:02:37.177183941Z",
      "provider": "osv",
      "upstream": [
        "CVE-2022-28366"
      ],
      "references": [
        "https://security-tracker.debian.org/tracker/CVE-2022-28366"
      ]
    },
    "related_cves": [
      {
        "value": "CVE-2022-28366",
        "evidence": "/upstream"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 323775,
  "published_at": "2022-04-21T23:15:10.383+00:00"
}